9 Replies Latest reply on Oct 12, 2017 6:46 AM by AgusYunjaya

    PI AF System Explorer Plugins

    AgusYunjaya

      Hi All,

       

      Apologize if this is not the best place for the posting regarding AF Explorer.

       

      I am trying to load third party application plugins, called Sigmafine, on PI System Explorer.

      Sigmafine has AF Plugin (AFPlugInAnalyses.dll) which needs to be paste locally in PIPC\AF\ folder.

       

      But whenever I open the PSE, this particular plugin is not loaded.

      Is there any way to force (or any config file, registry editor...) PSE to load this plugins?

       

      PI AF version is 2016 R2 SP1, Sigmafine 4.6.7

       

       

      Thanks,

      Agus Y Adikusuma

        • Re: PI AF System Explorer Plugins
          messingerj

          Hi Agus,

           

          The last time I used Sigmafine, the Model Analyses plugin worked without any issues, and no special registration was required. I would ask which version of PSE are you using - the 32-bit legacy version, or the 64 bit version? Which PIPC directory did you put the Sigmafine plugin DLL into - C:\Program Files\PIPC (64-bit program location), or C:\Program Files (x86)\PIPC (32-bit program location)?

           

          I suspect that bitness version may be the issue here. In the absence of any specific installation instructions from Pimsoft, I would also suggest trying the DLL in both locations mentioned above, and the opening the corresponding version of PSE.

           

          Regards,

          John

            • Re: PI AF System Explorer Plugins
              AgusYunjaya

              Hi John,

               

              Thanks for responding.

              I am using PSE 32bit. Anyhow, I have copied the Sigmafine DLL into both C:\Program Files (x86)\PIPC\AF and C:\Program Files\PIPC\AF just to make sure.

              But the Model Analysis tab is still not loaded.

               

              I know that this is long known issues and known solutions by pasting the DLL into the AF folder, but this time does not work

              This is only happening in client machine, not on the server.

               

              Thanks & Regards,

              Agus Y Adikusuma

            • Re: PI AF System Explorer Plugins
              AgusYunjaya

              Hi All,

              We were given new AFPluginAnalyses.dll by Pimsoft as a workaround and solving this issue.

              It's a bit strange regarding the version, but it solved our problem.

               

               

              Regards,

              Agus Y Adikusuma