4 Replies Latest reply on Oct 13, 2017 3:40 PM by aatewologun

    OPC DA/HDA Server 2010 Compatible with Windows 2012 R2?

    wxz44428

      Is OPC DA/HDA server 2010 compatible with Windows server 2012 R2? I understand there are newer version of DA/HDA, but if we'd stick with version 2010, not sure if it would work just fine on Win2k12 R2.

       

      Also, where I can find the compatibility matrix of full OSIsoft product line? I see a few KB articles, but none shows OPC DA/HDA product compatibilities.

       

      Thanks,

       

      Joe

        • Re: OPC DA/HDA Server 2010 Compatible with Windows 2012 R2?
          aizar

          Joe,

          Officially the OPC DA Server 2010 was not tested with Windows Server 2012 R2. The specific requirements for OPC DA Server 2010, based on the manual, are:

          ·        PI Server 3.2 minimum, PI Server 3.3 or greater is recommended for full functionality.

          ·        PI SDK 1.3.8.388 or higher.

          ·        Microsoft Windows XP, 2003 Server, Vista, 2008 Server, 2008 Server R2 or Win7

           

          Some customers have mentioned running into DCOM issues when using this particular combination, as seen in this thread.

          It is recommended that you install the latest version of our products.

           

          Regarding compatibility, your best bet is to check each product's user's manual.

          Cheers!

          • Re: OPC DA/HDA Server 2010 Compatible with Windows 2012 R2?
            aatewologun

            The PI OPC DA/HDA Server 2010 supports and has been tested with both Windows Server 2012 and 2012 R2.

             

            For the OPC DA/HDA Server 2010, the product compatibility can be found in the user manual.

             

            Specifically, this is given:

            Requirements

            PI Server 3.2 minimum, PI Server 3.3 or greater is recommended for full

            functionality

            PI SDK 1.3.8.388 or higher

            Microsoft Windows XP, 2003 Server, Vista, 2008 Server, 2008 Server R2 or Win7

             

            OPC Compatibility

            OPC Data Access (DA) 2.05a

            OPC Historical Data Access (HDA) 1.2

             

            Thanks,

            Ayomide.