2 Replies Latest reply on Mar 18, 2019 1:35 PM by MariaMoore

    PI OLEDB Enterprise Provider in SSRS

    MariaMoore

      Hi!

       

      I am trying to connect to PI-AF in SSRS using the PI OLEDB Enterprise Provider. I have PI OLEDB installed on my local.

       

      Testing the connection in the SSRS Connection Properties is successful:

      But testing the connection in the Data Source Properties returns this: "The 'PIOLEDBENT' provider is not registered on the local machine."

       

      Does anyone know why the connection would fail on the PIOLEDBENT? It also fails with PIOLEDBBENT.1

       

      Thank you,

      Maria

        • Re: PI OLEDB Enterprise Provider in SSRS
          rschmitz

          Hi Maria,

           

          This error typically arises when PI OLEDB Enterprise is not installed on the same machine that has SSRS installed. I saw in your post that you installed the PI OLEDB Enterprise Provider locally, do you also have SSRS installed locally? If not, I would recommend installing the PI OLEDB Enterprise Provider on the machine running SSRS.

           

          Cheers,

          Rob

            • Re: PI OLEDB Enterprise Provider in SSRS
              MariaMoore

              Hi Rob,

               

              I do not have PI OLEDB Enterprise Provider installed on the machine running SSRS. I will see if it is possible to install on the server hosting the SSRS reports/Report Builder.

               

              I have a few more questions regarding this:

              • What would be the cause of the test connection succeeding in the first photo but not in the second? If Enterprise is not installed on the machine, shouldn't both tests fail?
              • Why would I have the option to choose PI OLEDB Enterprise Provider if it is not installed on the machine running SSRS? It was not available before installing on my local.

               

               

              Thank you!

               

              Maria