mathiak

Elements missing in the PI Vision AF database tree while the PI Web API Crawler is indexing

Discussion created by mathiak on Feb 13, 2020
Latest reply on Feb 17, 2020 by sraposo

Experts, 
I need your help to figure out what kind of workaround can be done for the below Known Issue in PI Vision.

https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=VisionMissingAFElementsNoneDR 

Issue

Sometimes certain elements do not appear when expanding the AF database tree in PI Vision. The issue may occur when the PI Web API Crawler is making an incremental crawl.
Knowledge

Solution

For any affected elements, check to see if both of the following are true:

 

  1. The element contains an attribute that has a Data Reference type of "None"
  2. The element has an Analysis that outputs to this attribute

 

OSIsoft does not recommend using attributes with Data Reference type of "None" as Analysis outputs. A solution would be to change the Data Reference type of all analysis output attributes from "None" to "PI Point". This will require 1 PI Point per attribute, because the value of the attribute will now be stored in a PI Tag on the PI Data Archive server.

K

 

My challenge here Sebastien Raposo

 Certain Attributes need not be stored as a PI Point. 
   Example : Analysis Expression -- TagName(), TagDesc(), and many other simple Expressions.

   This expression cannot be done in String Builder.So we chose to go with Analysis Output which is not stored as a PI Point. 

What can be done to these kind of simple calculations which really does not need  a PI Point ? 

 

Outcomes