AnsweredAssumed Answered

Supporting Multiple Versions of AF SDK

Question asked by brendanbell on Sep 14, 2015
Latest reply on Sep 15, 2015 by skwan

In our PI/AF environment we have some custom apps, interfaces, ACE calcs, etc.

We have recently upgraded our AF server to AF 2014 R2, and we want to start using the latest AF SDK for custom development.

We have some concerns that we might run into problems with upgrading and supporting our custom code since

- AF SDK 2015 requires .NET version 4.5 or above

- Older versions of Visual Studio do not support .NET 4.5

- Known issues with ACE calculations, PI Web Parts & ProcessBook plugins with .NET framework above 3.5


Can a single client machine support multiple versions of the AF SDK? My experience so far indicates not.

Do other OSI customers have any experience with similar dependency issues?

 

Thanks

Outcomes