1 Reply Latest reply on Sep 24, 2015 9:43 AM by pthivierge

    PIOLEDB in Altova MapForce

    TomMcCarthyNeoPLM

      Hi All,

       

      I am trying to use Altova Map Force to graphically develop my PI integration Solution.  When I add the PI OLEDB provider to the work surface of this application, I get an error (89132) and the application just crashes.  I have not tried the linked server approach, as I am trying to avoid that dependency.  I have filed a support ticket with Altova as well, but was wondering if anyone here has tried this before, and if there might be a workaround.

       

      Thanks

       

      Tom

        • Re: PIOLEDB in Altova MapForce
          pthivierge

          Hi Tom,

           

          I would recommend to turn on logging on the PI OLEDB Provider.  You can do that by passing parameters in the connection string.  Please refer to the documentation for that.

          Maybe this will give more details about what is happening.

           

          Also, it would be useful to know what provider and version you are using? OLEDB Enterprise or OLEDB Provider classic?

           

          Other remarks

          I would like to highlight here that the PI System is not a relational database.  And OLEDB Product are a commodity to access the data as if it was a relational database.  This makes a big difference.

          This also means that you need to have a relatively good understanding of what is happening behind when writing your queries.

          The type of tool you are trying to configure may generate unsupported queries and also sub-optimal queries and performance may suffer from that.

           

          I also normally recommend these readings when working with OLEDB Products:

          PI OLEDB Enterprise Optimization White Paper

          PI OLEDB (Classic) SQL Optimization White Paper

           

          I hope this helps and please let us know how it goes on your end