AnsweredAssumed Answered

What has to be done in order to get the WebSocket enabled for PI Web API 2015 R3?

Question asked by shillman Employee on Nov 4, 2015
Latest reply on Nov 5, 2015 by dng

I have recently upgraded to PI Web API 2015 R3. I am testing out the new Channel functionality. However, I cannot seem to get it to work. I am using a Windows Server 2012 R2 machine configured as a web server. I have enabled HTTP Activation and WebSockets, among other things.


I have tried using simple WebSocket test clients to no avail. I have tried a simple C# application and a simple js application, both modified examples of what is included with the PI Web API help (By modified I mean that I simply changed the WebID to point to one of my PI points and the URL to point to my PI Web API machine). Typical PI Web API calls, such as getting the snapshot from the value stream, work as expected.


I have never been able to do so much as connect to the WebSocket, from the looks of it... For example, the simple C# console application from the examples fails when it attempts to connect and simply spits out the preconfigured exception message for that, "Could not connect to server".


From this same machine, in the same browsers or with similar simple applications, I am able to connect to other WebSocket servers.


Is there something I need to do on the PI Web API side to enable WebSockets? Are there limitations to this, like it only accepts a certain type of security? Any ideas would be very helpful. Thank you!