2 Replies Latest reply on Nov 13, 2015 7:03 PM by Marcos Vainer Loeff

    Powershell not returning the Archive_AutoArchiveFileRoot parameter value

    Robert Raesemann

      I've got a client with several servers with old archives that have been haphazardly named over the years. I've used various methods to correct this in the past, but have reading PowerShell to the rescue; solving the PI Server Archive Management shortcomings , I wanted to use Powershell to fix it.

       

      The servers that I am running this on are all running PI 2015 R2. There have been some changes to the PI Powershell tools since Rhyse wrote the original post. I've run into a snag. When I try to retrieve the AutoArchiveFileRoot parameter, the call does not return the Value. It returns the name, description, etc., but not the value, which is always null...

       

      $myPI = Connect-PIDataArchive -PIDataArchiveMachineName vCampusPiServer

      $AutoArchiveFileRoot = (Get-PITuningParameter -Name "Archive_AutoArchiveFileRoot" -Connection $myPI)

       

      I can inspect the variable and see that the other fields except the Value are returned properly...

      The value is definitely set, I can see it in the SMT. Here is a screenshot...

      I've tried this on my development server, and on two of the customer's servers. They are all running PI 2015 R2. The value is null on all three. Is this a bug or am I missing something? I get the same result when trying to get the file extension as well. It returns the default and other parameters successfully, but the Value is always null.