9 Replies Latest reply on Dec 9, 2015 1:45 AM by Argel

    Unable to open a session on a server

    Argel

      Hi Everyone!

       

      I have these bugging error on PSE "PI point not found" (I have everything working before, idk what I did to have this error) and when I looked at the message on PI SMT I have this message:

       

      On one machine, this is the error:

      Unable to open a session on a server. [-10758] Failed to create remote connection.

       

      On the other machine, this is the error:

      Unable to open a session on a server. [1225] Failed to create remote connection.

       

      I read a thread regarding troubleshooting KB01154 - Troubleshooting connectivity to the PI System and I observed that my port 5450 is not on the available ports list

       

      On the other hand, in this thread (same question) Unable to open a session on a server (I marked it I have the same question) they say that PI Base Subsystem should be running

       

      When I checked my available services, PIBASESS is not on the list.

       

      Please help me!

        • Re: Unable to open a session on a server
          Rhys Kirk

          Ports 5457 and 5459 are listening, they are the AF Server ports.

          It looks like you may be trying to connect to the AF Server and not the PI Data Archive server.

           

          Check to ensure you are connecting to the correct machine.

            • Re: Unable to open a session on a server
              Argel

              Please help me!

               

              Here is a snapshot of my PI Client machine which cannot get values:

               

              Both ports for PIServer and AF Server are not available

                • Re: Unable to open a session on a server
                  Rhys Kirk

                  The ports will only show up if you have either the AF Server or the PI Server installed locally.

                  You are already connected to both AF and PI from your client machine, I can see that from the Foreign Addresses.

                   

                  Your PI Data Archive = pi-srv-sec

                  Your AF Server = pi-srv-2014

                   

                  When you define a PI Point data reference in an AF Attribute make sure you are using the prefix of "\\pi-srv-sec\" followed by the tag name you need.

                    • Re: Unable to open a session on a server
                      Argel

                      What if I want to pi-srv-2014 as my PI Data Archive as well, how can I do that? Is that possible?

                       

                      because actually before my pi-srv-2014 is both my pi data archive server and af server as well (though this is not good practice but just for simulation) and pi-srv-sec is my failover (secondary pi server) and i honestly don't know how this jumble of function happened.

                       

                      I'm sorry I'm a newbie here

                        • Re: Unable to open a session on a server
                          Rhys Kirk

                          That appears to be your AF Server because you are connected over port 5457.

                          If you want that to be your PI Data Archive too then you need to install the PI Data Archive on that same machine.

                            • Re: Unable to open a session on a server
                              Argel

                              How can my tell my client machine to connect port 5450 to pi-srv-2014?

                               

                              I checked my SDK connection and it is connected to pi-srv-sec but when I switch to pi-srv-2014 this error pops up:

                               

                                • Re: Unable to open a session on a server
                                  Rhys Kirk

                                  The PI Data Archive isn't installed on that machine? i.e. you have a false PI Collective, or used to have a PI Collective then someone remove it?

                                  The PI Data Archive isn't started up?

                                  Firewall is blocking traffic? (Even Windows Firewall.)

                                   

                                  Maybe TechSupport can troubleshoot quicker.

                                  • Re: Unable to open a session on a server
                                    avanfosson

                                    Let's first verify that the PI Data Archive is installed on pi-srv-2014. Can you send us a screenshot of your services list?

                                    Services List.png

                                    The PI Base Subsystem must show up in the services list if the PI Data Archive is installed. If it does not show up, then the PI Data Archive is not installed on pi-srv-2014. If the PI Data Archive is not installed, then the collective information on your secondary PI Server is incorrect like Rhys Kirk said. You then have two options:

                                    1. Convert the PI Data Archive on pi-srv-sec into a standalone collective and connect to it instead of pi-srv-2014.
                                    2. Install the PI Data Archive software on pi-srv-2014 and add it to the collective on pi-srv-sec. That might be easier said than done depending on how wrong the collective information on pi-srv-sec is.

                                    If the PI Data Archive is installed, then there are three likely scenarios that would prevent the PI Data Archive from listening on port 5450.

                                    1. The PI Data Archive is stopped.
                                    2. The PI Data Archive is running in closed mode.
                                    3. The PI Data Archive is running in standalone mode.

                                    For each possible problem here is the solution:

                                    1. Start the PI Data Archive by navigating to the %piserver%\adm folder. Then find the file called pisrvstart.bat and run the file by double-clicking on it.
                                    2. To get the PI Data Archive out of closed mode
                                      1. Open a Command Prompt window.
                                      2. Type cd /d %piserver%
                                      3. Type cd adm
                                      4. Type piartool -sys -open
                                    3. To get the PI Data Archive out of standalone mode
                                      1. Open a Command Prompt window.
                                      2. Type cd /d %piserver%
                                      3. Type cd adm
                                      4. Type piartool -sys -standalone off
                                    1 of 1 people found this helpful