3 Replies Latest reply on Jul 13, 2016 6:47 AM by cvillanua

    IO rate page is disabled

    rahulmittal99

      I am trying to create IO rate tags for PI OPC HDA interface.

      But I am PI ICU is not allowing me to do so, as IO rate page is disbled.

       

      How to overcome this situation ?

       

      Message

       

      Current connection has no write permission to PI points DB. IO rate page is disabled.

        • Re: IO rate page is disabled
          cvillanua

          Hello Rahul,

           

          The error that you are having is due to permission issues, it looks like the mapping or PI Trust that is connecting to your  PI Data Archive do not have the correct permissions to write into your PI Points DB.

          You could double check what type of permissions you have in order to access to your PI Data Archive following this steps:

           

          You might also be seeing the following symbol in the PI ICU ( Interface Configuration Utility ), which means that you cannot edit the interface instance.

          1. Go to PI SDK Utility -> Connections and click on the PI Data Archive check box.

          2. In the red box you can see how my user is connected to the PI Data Archive as piadmin|piadmins|PI 1| PIWorld.

          3. If I open my PI System Management Tool -> Security -> Database Security

          4. I can see how my user's PI Identity ( piadmin) has the access to read and write in the PIPOINT database.

          Please double check what type of connection your user/machine has to the PI Data Archive and see if you have the correct access in order to fulfil your goal of creating new IO Rate points.

           

          Also please have a look to the following set of videos about PI Server security OSIsoft: What are Identities, Mappings, & Trusts? (High Level PI Server Security Map) - YouTube

           

          After the correct configuration you should see the following:

           

           

          Thank you,

           

          Carlos.

            • Re: IO rate page is disabled
              rahulmittal99

              Thanks Carlos for your inputs.

              This is the first thing which I thought and checked.

               

              Believe me, I was making bigger silly mistake.

               

              The interface was running under a local account (Lets say A) and I logged into server thru another local account (lets say B).

              So when I opened ICU , it was thru B login id and I got this error. After troubleshooting above steps (mentioned by you), I found myself correct.

               

              And then it suddenly clicked me to use login id A, and it worked.

               

              Anyways Thanks