7 Replies Latest reply on Sep 21, 2016 12:58 PM by Marcos Vainer Loeff

    AF SDK Calls Depending on .NET 4.0 Only?

    Steve Boyko

      I'm developing a small application for a client to search for certain event frames and write the count to a PI tag. I built this on my system and it works fine, but the client's server doesn't have .NET 4.5... just .NET 4.0 Client Profile.

       

      When I build against .NET 4.0 Client Profile I get the message

      The primary reference "OSIsoft.AFSDK, Version=4.0.0.0, Culture=neutral, PublicKeyToken=6238be57836698e6, processorArchitecture=MSIL" could not be resolved because it was built against the ".NETFramework,Version=v4.5" framework. This is a higher version than the currently targeted framework ".NETFramework,Version=v4.0,Profile=Client".

       

      Is there any way around this, or do I need to have the client install .NET 4.5?