AnsweredAssumed Answered

Analysis functions not working properly in datalink.

Question asked by WCBrad on Oct 9, 2016
Latest reply on Oct 11, 2016 by jru

Hi All we are having a problem with data link in that analysis functions that are set to run periodically, but not write to a pi tag are failing to pass to calculated data function in datalink.

 

We have a large number flow meters in use. Due to difference in standards over time, some have functional totalisers, others do not. For the totaliser meters, I'm using the following formula

 

TagVal('Flow totaliser','*')>=TagVal('Flow totaliser','*-24h')then TagVal('Flow totaliser','*')-TagVal('Flow totaliser','*-24h') else TagMax('Flow totaliser','*-24h','*')-tagval('Flow totaliser','*-24h')+TagVal('Flow totaliser','*')

 

This is just to catch the memory resets that occur periodically. The equation is set to run once every 24 hours. These do not write to a pi tag.

However, if I try to average the month's values it brings up the error "Data item not supported by function".

 

Other equations which also have the periodicity set, bring up the same error.

However; equations which do not have a fixed periodicity work fine in Datalink.

 

To make things more complicated, these equations worked in Datalink for a period and then overnight stopped working. Our Pi support team said nothing changed server side, and I changed nothing in AF. An additional aspect is that if I calculate the mass load (ie flow * concentration) I can get a result out, despite the fact that one of the feed attributes doesn't work, but if both values are from flow meters it returns an error of "None of the input attributes support the recorded values method".

 

Any advice anyone has would be greatly appreciated, I'm getting up to releasing portions for public use, but cannot do that, whilst such a fundamental component is not working.

Regards,

Brad

Outcomes