AnsweredAssumed Answered

Issue with Pi-SNMP and v3 agents

Question asked by DSmith1 on Oct 20, 2016
Latest reply on Nov 30, 2016 by tmcmanus

I'm living a nightmare trying to get Pi-SNMP to work. We've been at it for 4 weeks now and still it cannot work the way it should.

 

The issue is a set of network devices with SNMP v3 running on them. I've set up the SNMP interface (version 1.5.1.306) to poll for data. One of the following will happen:

 

  1. All the SNMP v3 devices will initially send a value back to their Pi tags. Afterwards, only one type of device will send data back and all other tags for the other devices will write I/O timeout to them.
  2. Only one type of device will send an initial value back to its Pi tags. The other types of devices will immediately write I/O timeout to them.
  3. If I turn off one type of device, then a different device will become the main communicator while all the others either respond once or not at all and then write I/O timeout.

 

By "types of devices" I mean this. There are Linux devices with SNMP running on them and Windows devices running SNMP. Each Linux device (plux1, plux2) has approx. 30 Pi tags associated with them. And each Windows device (pwin1, pwin2) has about 6 Pi tags associated to them. The Windows devices running SNMP are running version 2c.

 

The windows devices running 2c have absolutely no issue. They work great. It's these Linux devices with SNMP v3 that are not playing nicely. It can't be firewall, because each device responds correctly if another devices' scan is off or if I run snmpget on them. It can't be incorrect OID, because of the reasoning I just gave about the firewalls.

 

We've scoured the techsupport site and SNMP user guide and tried everything: increasing timeouts, increasing retries, trying separate scan classes etc. Nothing seems to work.

 

Any ideas? Has anyone ran into this issue?

 

Weird note, when I run snmpget to poll the Linux SNMP v3 devices they respond just fine but they say SNMP-v2. Shouldn't it return v3? EDIT: Maybe I'm reading the output from snmpget incorrectly. If I send an snmpget -v 3 -l blah blah blah to the device I get this response:

 

SNMPv2-SMI::enterprises.Id number = hostname: 500

 

Is the "SNMPv2-SMI::" saying that the snmp version on the DEVICE is v2? Or something else?

 

 

Message was edited by: Daniel Smith

Outcomes