AnsweredAssumed Answered

Batch request error: Parameter 'intervals' is greater than the maximum allowed

Question asked by arosenthal on Nov 11, 2016
Latest reply on Nov 15, 2016 by schristian

I am trying to use the PI Web API batch controller to request a streamset for many attributes with the PlotValues method. However, when I have two many webIds in my request I sometimes receive the following error:

Parameter 'intervals' is greater than the maximum allowed (173).

Of course the number in the error message changes depending on the parameters of my batch request.

 

Is there a way for me to calculate how many webIds I can fit in a single batch sub-request resource (which also apparently is limited by a maximum URL length of 65536) based on the value of my 'intervals' parameter for a call to PlotValues? If I can calculate what this upper limit is, then I can split my requests up into multiple sub-requests to get all the data I want.

Outcomes