AnsweredAssumed Answered

error while deleting bulk data

Question asked by Paurav Joshi Champion on Dec 1, 2016
Latest reply on Jan 12, 2017 by gachen

Hello Folks,

 

I have to delete bulk data, i.e. only 700 rows in OLEDB, and options I have used are PI SQL Commander and piconfig.

 

With PI SQL Commander I executed delete query which has been successfully completed, but when I checked data via OLEDB SELECT query after 2 days, data is still there.

I don't know why?

 

I tried then piconfig utility to delete data, which in trail successfully worked on sinusoid tag, but when I put actual data to be deleted it gave me error as follows:

I copied the tag which is in text file as well as in last line of screenshot under <>, and put it under SMT -> Point Builder to check if there is something wrong with tag name.

There is nothing wrong in tag-name also, because as soon as I pasted tag-name it showed me whole point configuration of it.

 

Script that is in text file is as follows:

 

So I have two queries here:

  1. Above text file script worked for sinusoid tag, and not working for actual tags data to delete?
    (I got actual tagname by querying via OLEDB)
  2. Why PI SQL Commander executed delete query, but data still there?

 

Versions:

PI OLEDB Enterprise 2012

PI Server 2012 (Data Archive 2012)

 

Thanks,

Paurav Joshi

Outcomes