6 Replies Latest reply on Dec 23, 2009 11:30 PM by formerpigeek

    Not seeing the whole range of buttons in the text editor

    Daniel Takara

      Cristobal Escamilla

      Make osisoft.com a Trusted site, and in the trusted sites tell it to allow javascript. That should fix this.

       

      I was having the same problem as Carrie in IE8 here. Adding osisoft.com to the list of trusted sites fixed the issue for me. Thanks, Cristobal!

       

      By the way, I also investigated a little the exact IE8 scripting security settings that need to be enabled, so that the vCampus WYSIWYG edition buttons become enabled.

       

      In order to do that, I removed osisoft.com from the list of trusted sites and observed the default security settings for Internet Zone. I found out that the "Active scripting" setting (in Portuguese: "Script ativo") is enabled, by default. However, the following settings are not enabled by default:

      • "Allow updates on status bar via script" (in Portuguese: "Permitir atualizações da barra de status via script")
      • "Allow websites to prompt for information using scripted windows" (in Portuguese: "Permitir que sites solicitem informações usando janelas controladas por script")

      After I enabled these 2 settings, the WYSIWYG edition buttons became enabled.

       

      IE8_2D00_InternetZoneSecuritySettings.JPG

       

      However, regardless of having osisoft.com in the list of trusted sites or having internet zone settings in IE8 as I indcated above, sometimes I have to refresh the page (hitting the F5 key), so that the WYSIWYG edition buttons become enabled.

        • Re: Not seeing the whole range of buttons in the text editor

          Just like you guys, I sometimes do not see the whole range of buttons in the text editor - only new posts only, never on replies or editions of a post.

           

          What I found works is, if you just click on the Preview tab and then come back on the the Compose one, the buttons reappear magically! I find it better than hitting the F5 key to refresh, since you may have typed some text already which you'll lose... This seems like a bug in the "community platform" we are using for vCampus - which is, by the way, undergoing an upgrade project as we speak. This upgrade should take care of a number of little things that were reported over time

           

          Hope this helps!

          • Re: Not seeing the whole range of buttons in the text editor
            formerpigeek

            Hi All,

             

            I'm one of the original developers who worked on vCampus and I've been looking into the issue.  I'm also running IE8, but I have not been able to reproduce it.  The HTML editor is a third party component, and is probably beyond our control to fix even if we discover what's causing the issue.  Hopefully this will resolve itself when we upgrade the site. 

             

            I have noticed that IE8 doesn't play nice with some plug-ins.  I had a problem where IE8 was reporting a crash regularly and discovered when I turned off my Skype IE plug-in the problem stopped.  So if you haven't tried this already, turn off your plug-ins one at a time and see if the issue goes away.

             

            Thanks,
            Stephan