6 Replies Latest reply on Feb 17, 2010 7:21 PM by spilon

    Processbook Add / Installation Problem

    wpurrer

      I have two machines (both windows 2008 R2 with processbook installed)

       

      on Machine A)

       

      => My Development - Machine the Plugin Works

       

      => the only difference is the Visual Studio 2008 is on AInstalled

       

      => Funny is, the plugin is neither in the registry (pisystem/pi-processbook/addins) or in the processbook - folder (like sugggested in some message in this forum or in the pdf from the web seminar)

       

       

       

      on Machine b)

       

      => i can't get the addin appear in the Addin Manager (also no error messages)

       

      => i copied it in the processbook directory ... no success

       

      => i registered it through regadd.reg ... no success

       

      => i registered it through regasm ... no success

       

       

       

      Has someone has an idea ... what i can do ?

       

       

       

       

        • Re: Processbook Add / Installation Problem

          Wolfgang Purrer

          Funny is, the plugin is neither in the registry (pisystem/pi-processbook/addins) or in the processbook - folder
          Not having the add-in identified in the registry seems improbable to me... that's what PI ProcessBook relies on to load add-ins at startup. Are you sure you checked under the HKEY_LOCAL_MACHINE key, not the HKEY_CURRENT_USER?

           

          You should see your various add-ins listed as keys under HKEY_LOCAL_MACHINE\SOFTWARE\PISystem\PI - ProcessBook\Addins - they should be named after namespace.class convention as your assemblies are registered.