TelventMDM

Problems when using SIS and OSI adapters on .Net 4.0 (and solution)

Discussion created by TelventMDM on Apr 26, 2010
Latest reply on Apr 26, 2010 by richard

Looks like there is a load issue when using DLLs from both .net 4.0 and the SIS OSIsoft adapters. You get a runtime error.

 

The solution is to add the folloing to your app.config file:

 

<startup useLegacyV2RuntimeActivationPolicy="true">

 

Not sure all the details of why, but there is a pretty good explanation here: http://msdn.microsoft.com/en-us/library/bbx34a2h.aspx

 

Hope OSIsoft solves this issue soon, so we do not need this workaround, as it may interfare with other things.

Outcomes