MSEConsultants

PI-ACE sometimes returning "Calc Failed"

Discussion created by MSEConsultants on Jul 7, 2010
Latest reply on Jul 13, 2010 by MSEConsultants

Hi,

 

I'm new to PI so please excuse me if my question is elementry.

 

I have set up a test server and I'm using DataLink to populate my "raw data" tags on a timer to simulate reading field data. I have also written a PI-ACE module which is set to read some of the raw data tags, calculate about 15 result values and these get written back to PI output tags. It is set to run every 30 seconds in PI-ACE Manager.

 

Everything works really well for hours at a time, however on average once a day, the PI-ACE module stops working. All the tags I'm calculating say "Calc Failed". In PI-ACE Manager the current status is still "On". I can go back and recalculate and that does sporadic calculations (ie: not every 30 seconds even though I set the interval to 30 secs) and when I trend the recalculated values it doesn't join up most of the dots to make a trend. I can stop and start the PI-ACE module and it still says "Calc Failed".

 

If I try to debug the module and step through, it works fine. I thought it could be data related so I've tried stepping through in debug mode a number of times thereby trying to catch it with different data. It always works fine when I debug.

 

I have tried stopping PI and starting it again, but that doesn't make any difference. The only way I have found to get it working properly again is to stop PI (PISrvStop.bat) and reboot. After reboot everything is back to normal again for a good few hours.

 

Here is a trend of one of my calculated values to try help explain the problem:

 

http://www.mseonline.co.uk/temp/PIAceProblem.PNG

 

Any tips? (thanks )

 

Flic

Outcomes