8 Replies Latest reply on Jan 31, 2013 3:34 PM by mhamel

    PI System not found

    farooquf

      Hi,

       

      I'm calling af: path from PITimeSeries service. While executing a test case, I 'm getting an error "PI System not found" in response message.

       

      If I m correct this error comes when AF server is not configured in PI SDK connection of the web-server? Isn't it?

       
      -<GetPIArchiveData>
      -<MethodParameters>
      -<TimeSeriesArray>
      -<TimeSeriesArray0>
       <TimedValues attr0="TimedValueArray"isNull="false"/>
       <Path>af:\\SERVER123\SSNDB\ELEC_001\Input001\_Totalizing_Total_Energy_RateA__(kVARh)</Path>
       <ErrDesc>PI System not found</ErrDesc>
       <Error>2001</Error>
       <SeriesID>61c8ea7d-4b1f-467e-8564-3c8fa2dc7aa1</SeriesID>
       <DataType isNull="true"/>
       <UOM isNull="true"/>
       </TimeSeriesArray0>
       </TimeSeriesArray>
       </MethodParameters>
       </GetPIArchiveData>

      Thanks,

       

      Farooq

        • Re: PI System not found
          Ahmad Fattahi

          According to the troubleshooting section of the PI Web Services User Manual this error happens when the AF Server is not running. Can you confirm it is running?

           

          Another test you could do is to use another client to the AF Server, for example PI System Explorer, on the same box as the PI Web Services; you can try to connect and do some basic operations. Depending on the result we can continue troubleshooting.

           

          In some other cases, security settings on the AF Server might lead to the same error.

            • Re: PI System not found

              Depending on the architecture you are using PI Web Services in, it might very well be a network connectivity issues whereby the appropriate ports are not open in the firewall - please see the "Configure Firewall Exceptions" section in the PI Web Services User Guide.

                • Re: PI System not found
                  farooquf

                  >>ErrDesc>PI System not found</ErrDesc>

                   

                  Is resolved by adding AF system name in PI System Explorer ( in web-server).

                   

                  There are many gaps in the service manual.

                    • Re: PI System not found

                      Oh, absolutely: the PI AF Server you mean to connect to must be "known" to the system you are running PI Web Services on (same holds true for PI Data Archive). What you did is you added the server to the Known Servers List... sorry nobody came up with that suggestion earlier! I'll touch base with the team and make sure we document something about this in the manual.

                       

                      Regarding your statements about "many gaps in the manual", I would like to kindly invite you to capture these in an email and send that over to our regular Technical Support team. They will file these in as documentation-related enhancement requests, and these will get tackled appropriately by our Technical Writing team.

                        • Re: PI System not found
                          chris_capula

                          Hi All,

                           

                          I am encountering a similar issue to this at the moment but only for the first few requests I make.

                           

                          I am making a large number of PI web service calls in one go which pass in an AF reference, but quite often, (and only when I first use the application), the first few results return 'PI System Not Found'. After the first few have returned with this error, the rest are normally fine.

                           

                          I have tried increasing the PISDK connection timeout on the webserver and all the required firewall ports are open, and the PI Server is in the known server table.  

                           

                          If anyone has encountered a similar issue or has any suggestions I would be very grateful,

                           

                          Chris

                            • Re: PI System not found
                              andreas

                              Chris - how long does it take to connect to the AF server from the webserver? Can you try PI System Explorer on the web server?

                                • Re: PI System not found
                                  chris_capula

                                  Hi Andreas,

                                   

                                  I do apologise for not getting back to you, I never saw the reply,

                                   

                                  From selecting PI System Explorer to it actually opening is around 20 seconds, however the connecting to server dialogue(which it connects to automatically)  is only visible for around a second.

                                   

                                  Chris

                                    • Re: PI System not found
                                      mhamel

                                      @Chris: I would suggest you enable the tracing of PI Web Services to get more details about the problem. I invite you to take a look at the PI Web Services documentation under the Logging and instrumentation section. Essentially, you will change the logMode from warnings only to all. It will give you more details when calls are performed against the PI Web Services. All messages will be reported thereafter under the Windows Event Log categorized as Application related.