4 Replies Latest reply on Nov 9, 2015 3:02 PM by STBValitech

    PINET: RPC is Non-Existend

    hodneeri

      Hi,

       

       

       

      I have a PI server running on a Windows Server 2008 64 bit machine. This was running fine a few days ago, but when I tried to reach it today, I get a message saying Error: Unable to open a session on a server. [-10717] PINET: RPC is Non Existent Error number -2147220478

       

      I suspect windows has installed some updates, which caused this. Is there anyone who has encountered this before, and can tell me how to get acces to my server again? I get the same error message trying to connect both from the server itself and from another computer. I have turned off the windows firewall to make sure it is not creating any trouble, and I have checked that the Remote Procedure Call service is running.

       

       

       

      Regards,

       

      Erik

        • Re: PINET: RPC is Non-Existend
          dtakara

          Hi Erik,

           

          This error is quite generic and might be caused by several issues. To get them cleared, we kindly invite you to contact our regular Technical Support, using any of these contact methods.

           

          As you cannot connect to the PI Server from the server itself, the Technical Support team will probably ask to access your system remotely, to be able to see your issue first hand and maybe start the PI Server subsystems interactively, to help determine if a specific subsystem is in trouble or not.

           

           

            • Re: PINET: RPC is Non-Existend
              MichaelvdV@Atos

              I can remember I had this issue a couple of times on my development machine, also a Windows 2008 R2 system.

               

              I'm not sure about the root cause. Because it was a development machine, I just rebooted the OS and it then works again.

               

              To get proper answers to your questions, you should contact techsupport like Daniel suggested.

                • Re: PINET: RPC is Non-Existend

                  "root cause":

                   

                  Each PI subsystem publishes a set of RPC's to client applications that it can answer.  If a subsystem is shut down (or otherwise goes away), the RPC's serviced by that subsystem are no longer available.

                   

                  Client applications are periodically updated by pinetmgr with the current list of available RPC's.  Thus, the RPC is non-existent according to the error report.

              • Re: PINET: RPC is Non-Existend
                STBValitech

                Hi,

                 

                I have the same issue today. It was resolved easly because one service: PI Buffer Subsystem is not started. After I re-started I don't have this error anymore.

                 

                Could be help someone.

                 

                Regards,

                Francesco