Does AF SDK require .NET Framework 3.5 or 4.0?

Discussion created by Development on Aug 23, 2011
Latest reply on Aug 26, 2011 by spilon



I have not found an official list of compatibility between the various versions of AF SDK  and the versions of  .NET Frameworks. Does one exist?


Searching for that information, I found a previous post in these forums, which said that" AFSDK uses WCF to communicate to the AF Service which is only available in .NET 2.0.  In addition, there are changes to .NET DateTime in .NET 2.0 that AF makes specific use of.  " (from URL:


Based on our own testing with OSIsoft.AFSDK.dll, version, we found implicit dependencies on libraries in .NET 3.0 and .NET 3.5:


Here is a sample warning that I get when trying to target .NET 2.0:


"Warning        The primary reference "OSIsoft.AFSDK, Version=, Culture=neutral, PublicKeyToken=6238be57836698e6, processorArchitecture=MSIL" could not be resolved because it has an indirect dependency on the framework assembly "System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" which could not be resolved in the currently targeted framework. ".NETFramework,Version=v2.0". To resolve this problem, either remove the reference "OSIsoft.AFSDK, Version=, Culture=neutral, PublicKeyToken=6238be57836698e6, processorArchitecture=MSIL" or retarget your application to a framework version which contains "System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089".    "


It also wanted to find  "System.Core, Version=", "WindowsBase, Version=" ,"System.IdentityModel, Version="  and "System.IdentityModel.Selectors, Version=" .


My conclusion is that AF SDK version 2.0 requires .NET 3.5 or .NET 4.0. Is that correct?




Nils A Thommesen, ExproSoft