AnsweredAssumed Answered

IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {385093D6-B6ED-4B79-B677-41584BB13F34}. Returned error: 259

Question asked by M.Keggenhoff on Mar 14, 2017
Latest reply on Mar 14, 2017 by kduffy

Ich habe versucht PI ActiveView zu installieren, bekomme allerdings diese Fehlermeldung.

 

==>> Begin InstallThread <<==
=============================
Looking for initialization file at: C:\pisetup.ini
Found [SETUPKIT] NAME = ActiveView
Installation started at Tue Mar 14 11:35:04 2017
--- >>> Setup Module 1
Loading: 1 (\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\dotnet35Setup.dll)
dotnet35Setup> Using setup kit name dotnetfx35setup.exe
SetupUtils> Successfully found version 3.5.30729 for Module dotnet35Setup (Section 1) in setup.ini file.
dotnet35Setup> The version of the .Net Framework to be installed is 3.5.30729
dotnet35Setup> The version of the .Net Framework on the destination machine is 3.5.30729
CompareVersions> NewVer4 not found...padding with 0
CompareVersions> InstalledVer4 not found...padding with 0
CompareVersions> Versions identical...returning 0
Setup Module 1 (dotnet35Setup) is already installed.
--- >>> Setup Module 2
CompareVersions> NewVer4 not found...padding with 0
CompareVersions> InstalledVer4 not found...padding with 0
CompareVersions> NewVer3 < InstalledVer3...returning -1
IsMSIInstalled> The installed version 3.1.8 is newer than the version to install 3.1.6 - returning TRUE.
Setup Module 2 (MSRuntimes.msi) is already installed.
--- >>> Setup Module 3
Setup Module 3 (MSRuntimes_X64.msi) is already installed.
--- >>> Setup Module 4
Setup Module 4 (MSRuntimes_318.msi) is already installed.
--- >>> Setup Module 5
Loading: 5 (\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\dotnet40Setup.dll)
dotnet40Setup> The version of the .Net Framework to be installed is 4.0.30319
dotnet40Setup> The version of the .Net Framework on the destination machine is 4.6.01055
CompareVersions> NewVer4 not found...padding with 0
CompareVersions> InstalledVer4 not found...padding with 0
CompareVersions> NewVer2 < InstalledVer2...returning -1
Setup Module 5 (dotnet40Setup) is already installed.
--- >>> Setup Module 6
Setup Module 6 (vc_red.msi) is already installed.
--- >>> Setup Module 7
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {9A1A3A9E-DF93-48EF-A658-C052B3148BF9}. Returned error: 259
Calling InstallModuleAndReturnErrorCode for Setup Module 7 (pisdk.msi) at Tue Mar 14 11:35:13 2017
SetRunOnceKey> Setting Run Key to \\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\setup.exe 7
SetRunOnceKey> Closing Run Key and returning TRUE
pisdk> Installation Command is C:\WINDOWS\system32\msiexec.exe /i "\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\pisdk.msi" /l*v "C:\Setuppisdk.log" REBOOT=Suppress ALLUSERS=1  PIBUF_DLG=0 NOPISDKBUFFERING=1 EXIT_DIALOG=0
pisdk> Setting reboot flag to false
SetupUtils> Copying C:\Setuppisdk.log to C:\Program Files (x86)\PIPC\dat\Setuppisdk.log
InstallModuleAndReturnErrorCode SUCCEEDED at Tue Mar 14 11:36:11 2017, bRebootNeeded = 0, dwErrorCode = 0
Run key has been cleared for Setup Module 7 (pisdk.msi).
Verification SUCCEEDED for Setup Module 7 (pisdk.msi).
--- >>> Setup Module 8
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {1F1B5727-9E75-4F6E-8647-DDD888DC52F2}. Returned error: 259
Calling InstallModuleAndReturnErrorCode for Setup Module 8 (pibufss.msi) at Tue Mar 14 11:36:16 2017
SetRunOnceKey> Setting Run Key to \\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\setup.exe 8
SetRunOnceKey> Closing Run Key and returning TRUE
pibufss> Installation Command is C:\WINDOWS\system32\msiexec.exe /i "\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\pibufss.msi" /l*v "C:\Setuppibufss.log" REBOOT=Suppress ALLUSERS=1 /qb-
pibufss> Setting reboot flag to false
SetupUtils> Copying C:\Setuppibufss.log to C:\Program Files (x86)\PIPC\dat\Setuppibufss.log
InstallModuleAndReturnErrorCode SUCCEEDED at Tue Mar 14 11:36:42 2017, bRebootNeeded = 0, dwErrorCode = 0
Run key has been cleared for Setup Module 8 (pibufss.msi).
Verification SUCCEEDED for Setup Module 8 (pibufss.msi).
--- >>> Setup Module 9
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {AD7714C6-7563-4CF3-954A-C29093B388ED}. Returned error: 259
Calling InstallModuleAndReturnErrorCode for Setup Module 9 (PISDK_X64.msi) at Tue Mar 14 11:36:45 2017
SetRunOnceKey> Setting Run Key to \\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\setup.exe 9
SetRunOnceKey> Closing Run Key and returning TRUE
PISDK_X64> Installation Command is C:\WINDOWS\system32\msiexec.exe /i "\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\PISDK_X64.msi" /l*v "C:\SetupPISDK_X64.log" REBOOT=Suppress ALLUSERS=1  NOPISDKBUFFERING=1 EXIT_DIALOG=0
PISDK_X64> Setting reboot flag to false
SetupUtils> Copying C:\SetupPISDK_X64.log to C:\Program Files (x86)\PIPC\dat\SetupPISDK_X64.log
InstallModuleAndReturnErrorCode SUCCEEDED at Tue Mar 14 11:37:37 2017, bRebootNeeded = 0, dwErrorCode = 0
Run key has been cleared for Setup Module 9 (PISDK_X64.msi).
Verification SUCCEEDED for Setup Module 9 (PISDK_X64.msi).
--- >>> Setup Module 10
The Setup Module 10 (\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\AFClient_x86_2012SP2.msi) is not supported on WIN7SP1_X64 operating systems. Skipping.
--- >>> Setup Module 11
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {4EF3B527-049E-4042-94B5-C9E869C740BC}. Returned error: 259
Calling InstallModuleAndReturnErrorCode for Setup Module 11 (AFClient_x64_2012SP2.msi) at Tue Mar 14 11:37:42 2017
SetRunOnceKey> Setting Run Key to \\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\setup.exe 11
SetRunOnceKey> Closing Run Key and returning TRUE
AFClient_x64_2012SP2> Installation Command is C:\WINDOWS\system32\msiexec.exe /i "\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\AFClient_x64_2012SP2.msi" /l*v "C:\SetupAFClient_x64_2012SP2.log" REBOOT=Suppress ALLUSERS=1  ONLYSHOWSERVER=1 ADDLOCAL=ALL
AFClient_x64_2012SP2> Setting reboot flag to false
SetupUtils> Copying C:\SetupAFClient_x64_2012SP2.log to C:\Program Files (x86)\PIPC\dat\SetupAFClient_x64_2012SP2.log
InstallModuleAndReturnErrorCode SUCCEEDED at Tue Mar 14 11:39:01 2017, bRebootNeeded = 0, dwErrorCode = 0
Run key has been cleared for Setup Module 11 (AFClient_x64_2012SP2.msi).
Verification SUCCEEDED for Setup Module 11 (AFClient_x64_2012SP2.msi).
--- >>> Setup Module 12
Setup Module 12 (extensibilityMSM.msi) is already installed.
--- >>> Setup Module 13
Setup Module 13 (VBAOF11.msi) is already installed.
--- >>> Setup Module 14
CompareVersions> Versions identical...returning 0
IsMSIInstalled> The installed version 6.5.10.32 is the same as the new version to install 6.5.10.32 - returning TRUE.
Setup Module 14 (VBAOF11I.msi) is already installed.
--- >>> Setup Module 15
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {385093D6-B6ED-4B79-B677-41584BB13F34}. Returned error: 259
Calling InstallModuleAndReturnErrorCode for Setup Module 15 (ActiveView.msi) at Tue Mar 14 11:39:08 2017
SetRunOnceKey> Setting Run Key to \\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\setup.exe 15
SetRunOnceKey> Closing Run Key and returning TRUE
ActiveView> Installation Command is C:\WINDOWS\system32\msiexec.exe /i "\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\ActiveView.msi" /l*v "C:\SetupActiveView.log" REBOOT=Suppress ALLUSERS=1 TRANSFORMS=ActiveView.mst
ActiveView> Setting reboot flag to false
SetupUtils> Copying C:\SetupActiveView.log to C:\Program Files (x86)\PIPC\dat\SetupActiveView.log
InstallModuleAndReturnErrorCode FAILED at Tue Mar 14 11:39:35 2017. Installation error for Setup Module 15 (ActiveView.msi):[1603] Schwerwiegender Fehler bei der Installation.

InstallThread will terminate.
=============================
==>>  End InstallThread  <<==
=============================
--- >>> Setup Module 1
Setup module dotnet35Setup is check for install only (CHECKFORINSTALLEDONLY).
Loading: 1 (\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\dotnet35Setup.dll)
\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\dotnet35Setup.dll version 1.0.1.1
dotnet35Setup> Using setup kit name dotnetfx35setup.exe
SetupUtils> Successfully found version 3.5.30729 for Module dotnet35Setup (Section 1) in setup.ini file.
dotnet35Setup> The version of the .Net Framework to be installed is 3.5.30729
dotnet35Setup> The version of the .Net Framework on the destination machine is 3.5.30729
CompareVersions> NewVer4 not found...padding with 0
CompareVersions> InstalledVer4 not found...padding with 0
CompareVersions> Versions identical...returning 0
Module (Microsoft .NET3.5 Framework v3.5.30729) already installed.
--- >>> Setup Module 2
CompareVersions> NewVer4 not found...padding with 0
CompareVersions> InstalledVer4 not found...padding with 0
CompareVersions> NewVer3 < InstalledVer3...returning -1
IsMSIInstalled> The installed version 3.1.8 is newer than the version to install 3.1.6 - returning TRUE.
Module (OSIsoft MS Runtime Redistributables v3.1.6) already installed.
--- >>> Setup Module 3
Module (OSIsoft MS Runtime Redistributables x64 v3.1.1) already installed.
--- >>> Setup Module 4
Module (OSIsoft MS Runtime Redistributables v3.1.8) already installed.
--- >>> Setup Module 5
Loading: 5 (\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\dotnet40Setup.dll)
\\ohlesfile1\Abteilung\API\Software\Pi\ActiveView_3_4_0_(2014)\dotnet40Setup.dll version 1.0.0.0
dotnet40Setup> Found setup module file dotNetFx40_Full_x86_x64.exe
dotnet40Setup> The version of the .Net Framework to be installed is 4.0.30319
dotnet40Setup> The version of the .Net Framework on the destination machine is 4.6.01055
CompareVersions> NewVer4 not found...padding with 0
CompareVersions> InstalledVer4 not found...padding with 0
CompareVersions> NewVer2 < InstalledVer2...returning -1
Module (Microsoft .NET Framework 4 Setup v4.0.30319) already installed.
--- >>> Setup Module 6
Module (Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161 v9.0.30729.6161) already installed.
--- >>> Setup Module 7
Module (PI Software Development Kit (PI SDK) x86 v1.4.2.445) already installed.
--- >>> Setup Module 8
Module (PI Buffer Subsystem v3.4.380.79) already installed.
--- >>> Setup Module 9
Module (PI Software Development Kit (PI SDK) x64 v1.4.2.445) already installed.
--- >>> Setup Module 10
[UNSUPPORTED_OPERATING_SYSTEMS]: 10 = X64
Setup module AFClient_x86_2012SP2.msi is not supported on WIN7SP1_X64 operating systems.
CompareVersions> Versions identical...returning 0
IsMSIInstalled> The installed version 2.5.2.5396 is the same as the new version to install 2.5.2.5396 - returning TRUE.
Module (PI AF Client (x86) 2012 SP2 v2.5.2.5396) already installed.
--- >>> Setup Module 11
Module (PI AF Client (x64) 2012 SP2 v2.5.2.5396) already installed.
--- >>> Setup Module 12
Module (Shared Add-in Extensibility Update for Microsoft .NET Framework 2.0 (KB908002) v1.0.0) already installed.
--- >>> Setup Module 13
Module (Visual Basic for Applications (R) Core v6.5.10.53) already installed.
--- >>> Setup Module 14
CompareVersions> Versions identical...returning 0
IsMSIInstalled> The installed version 6.5.10.32 is the same as the new version to install 6.5.10.32 - returning TRUE.
Module (Visual Basic for Applications (R) Core - English v6.5.10.32) already installed.
--- >>> Setup Module 15
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {385093D6-B6ED-4B79-B677-41584BB13F34}. Returned error: 259
Module (PI ActiveView 2014 v3.4.0.279) will be installed.
----------------------
Completed Verification checks for all modules.
InstallThread Error 1603. Installation of PI ActiveView 2014 has failed.

Outcomes