AnsweredAssumed Answered

Analysis not outputting to attribute

Question asked by dleslie on May 16, 2017
Latest reply on May 20, 2017 by dleslie

Need some help with this one.  I have an analysis that has worked correctly for months, but has now, following a table update, stopped outputting results to the output attribute on our production system - it is still working as intended on our test system (table was updated there, also).  I've tried the following:

 

Attempt                                                                 Result

Stop/Start the analysis                                        No Change in results

Backfilled the analysis                                        Wrote to the tag, when the event ended it did not write to the tag

Deleted the Calculation, and recreated it            No Change in results

Manually entered a new event                            No Change in results

 

For reference, the calculation is below

Argument1          If Not BadVal('Atribute1') and  '*' >= 'Attribute1' and  Not BadVal('Attribute2') and '*' < 'Attribute2' then "True" else "False"

 

Argument2         IF 'Attribute3' = "No Data" Then 1 Else

                           IF 'Attribute3' = "True" Then 2 Else

                           IF 'Attribute3' = "False" Then 0 Else 1

 

Argument3         IF Argument1 = "True" and Argument2 = 2 Then "X" Else

                           IF Argument1 = "True" and Argument2 = 0 Then "Y" Else

                          "Z"

 

Argument4          If LCase(Argument3) <> LCase(String(PrevVal('OutputTag', '*-1s'))) Then Argument1 else NoOutput()

 

The calculation is periodic, and evaluates 1/minute

Outcomes