4 Replies Latest reply on Mar 18, 2019 3:12 AM by Henryk Schneider

    PI Datalink COM add-in not working

    narmi_shyam

      PI Datalink COM add-in disappeared from the Add-in list and I couldn't add it back. It says '..\OSIsoft.PIDataLink.UI.dll' is not a valid Office Add-in. I use the Excel version 2013 and Datalink version 2016. I tried trouobleshooting based on KB00265 but couldn't fix it.

        • Re: PI Datalink COM add-in not working
          flee

          Hi Narmadha,

          Have you tried checking the registry key at  HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\AddIns\PI DataLink. ?

          The LoadBehavior DWORD should be set to 3.

          Also check the registry for the Local Machine as well as current user.

           

          I am also curious, was the add-in visible before? If yes, did you do anything before it disappeared?

          1 of 1 people found this helpful
            • Re: PI Datalink COM add-in not working
              narmi_shyam

              Hi Frank,

              Thank you for your response. I did check the registry key for Local Machine and the LoadBehavior is set as 3. But I couldn't navigate to Excel\AddIns\PI DataLink through HKEY_CURRENT_USER because, under office\excel, I do not see AddIns folder but only the Add-in Manager folder and no Datalink under this.

               

              The COM Add-in for PI Datalink was available earlier and I was using the same last week. As it is in a shared machine, I assume some other user might have removed it by mistake. As mentioned in the KB00265, If the add-in is manually removed, I may need to re-install the PI Datalink to bring the add-in back. Please suggest if there is any other option.

               

              Thanks

              • Re: PI Datalink COM add-in not working
                Henryk Schneider

                Cheers Frank.

                This helped me fix an issue I was having with Excel 2010 and Datalink 2016 R2.  After activating the Excel Add-In, the ribbon would not appear, so I tried activating the PI Datalink Com Add-In, and in doing this, my PI Datalink Excel Add-In would get disabled.  Couldn't find any errors on it, and when I logged into the machine under a different profile Excel & Datalink worked fine out of box.  Logged back in as the affected user, checked that registry and set it to 3 (was 2), now seems to be working ok.

                Thanks,
                H

              • Re: PI Datalink COM add-in not working
                Lal_Babu_Shaik

                Hi Narmadha

                 

                Request you to check the post Problems to Display the Datalink Tab in Office 2016 32x . We have installed datalink on office 2010 ,2013 and 2016. I have  noticed issue with office 365 due to patch updates or excel crash where add-in is not loading correctly. I have tried all possible options mentioned in my post and able to solve most of the problems related to Datalink missing add-in.