AnsweredAssumed Answered

UFL -9999 Error with UFL 3.4.21

Question asked by I.Berry on Aug 2, 2017
Latest reply on Aug 8, 2017 by I.Berry

Hi,

I would appreciate some help with this UFL Error:

 

01-Aug-2017 22:42:01  [-9999]> ORION;PER;RSFAB;BASE;VG51;VOL;3.636099;15062017095933;15062017142628

 

Data file is processed and marked as _OK, but no values are stored in PI Server.

 

The input file data is like this:

ORION;PER;RSFAB;BASE;VG51;VOL;3.636099;16062017000002;15062017142628

ORION;PER;RSFAB;BASE;VG51;WGT;3.399781;16062017000002;15062017142628

*

My INI file is like this:

[INTERFACE]

PLUG-IN=AsciiFiles.dll

 

[PLUG-IN]

IFM=E:\DATA\Orion\*.csv

IFS=N

REN=_OK

ERR=BAD

PURGETIME=1d

PFN=False

NEWLINE=13,10

 

[SETTING]

DEB=6

MAXLOG=10

MAXLOGSIZE=20

MSGINERROR=E:\APPS\PIPC (x86)\Interfaces\PI_UFL\Logs\err.log

OUTPUT=E:\APPS\PIPC (x86)\Interfaces\PI_UFL\Logs\out.log

LOCALE=en-us

 

[FIELD]

FIELD(1).NAME="Tagpart1"

FIELD(1).TYPE="String"

FIELD(2).NAME="Value"

FIELD(2).TYPE="Number"

FIELD(3).NAME="Timestamp"

FIELD(3).TYPE="DateTime"

FIELD(3).FORMAT="ddMMyyyyhhmmss"

FIELD(4).NAME="Tagpart2"

FIELD(4).TYPE="String"

FIELD(5).NAME="Tagpart3"

FIELD(5).TYPE="String"

FIELD(6).NAME="Tagpart4"

FIELD(6).TYPE="String"

FIELD(7).NAME="Tagpart5"

FIELD(7).TYPE="String"

FIELD(8).NAME="Tagname"

FIELD(8).TYPE="String"

FIELD(9).NAME="DTString"

FIELD(9).TYPE="String"

 

[MSG]

'This is a value to send to PI

MSG(1).NAME="MSG_2"

MSG(1).EPC="Float32"

 

[MSG_2]

MSG_2.FILTER=C1=="ORION*"

Tagpart1=["*;(*);*;*;*;*;*;*;*"]

Tagpart2=["*;*;(*);*;*;*;*;*;*"]

Tagpart3=["*;*;*;(*);*;*;*;*;*"]

Tagpart4=["*;*;*;*;(*);*;*;*;*"]

Tagpart5=["*;*;*;*;*;(*);*;*;*"]

Value=["*;*;*;*;*;*;(*);*;*"]

DTString=["*;*;*;*;*;*;*;(*);*"]

Tagname=TagPart1&"."&Tagpart2&TagPart3&"."&Tagpart4&TagPart5

TimeStamp=DTString

StoreInPI(Tagname, ,Timestamp,Value, , )

 

 

Any idea? I suspect my Timestamp, but I can't seem to figure it out, I struggle with UFL debugging as the specific field it is having trouble with is not flagged (unless i have missed some logging setting!).

 

Thanks in advance!

Outcomes