AnsweredAssumed Answered

PI JDBC error in Linux

Question asked by GKaur on Aug 17, 2017
Latest reply on Aug 28, 2017 by gregor

Hi All,

 

Hope someone can help to resolve the issue I am facing below.

We are trying to get the data via PI JDBC (2016 R2) in a Linux server (Ubuntu 16.04.2 LTS) using Python and getting the below error.

 

 

*** Error in `python3': double free or corruption (!prev): 0x0000000002438840 ***

======= Backtrace: =========

/lib/x86_64-linux-gnu/libc.so.6(+0x777e5)[0x7f5381a987e5]

/lib/x86_64-linux-gnu/libc.so.6(+0x8037a)[0x7f5381aa137a]

/lib/x86_64-linux-gnu/libc.so.6(cfree+0x4c)[0x7f5381aa553c]

/opt/pipc/jdbc/lib/libRdsaWrapper64-1.5b.so(_ZNSt10unique_ptrI10NativeRDSASt14default_deleteIS0_EED1Ev+0x21)[0x7f52e4721951]

/lib/x86_64-linux-gnu/libc.so.6(+0x39ff8)[0x7f5381a5aff8]

/lib/x86_64-linux-gnu/libc.so.6(+0x3a045)[0x7f5381a5b045]

/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf7)[0x7f5381a41837]

python3(_start+0x29)[0x5d5f29]

 

Have someone faced the similar issues before?

 

Thanks,

Gurpreet

Outcomes