AnsweredAssumed Answered

PI OleDb Enterprise - Assertion failed

Question asked by Dries.Verhees on Aug 23, 2017
Latest reply on Sep 6, 2017 by ray

Hi all,

 

I am getting the following error with my PI OleDb query:

Assertion failed: type == At_Object || (type & At_Array) != 0

My query looks lie

select * 
from [xxx].[Asset].[lementHierarchy] eh
inner join [xxx].[Asset].[ElementAttribute] ea on (eh.ElementID =ea.ElementID)
inner join [xxx].[Data].[Snapshot] ds on (ea.ID = ds.ElementAttributeID)
where eh.Path = 'xxx' and eh.Name = 'xxx' and ea.Name = 'xxx'

 

I am not sure if it is related to this thread: PI OLEDB "Assertion failed" error when querying [db1].[Asset].[ElementAttribute] , since I am using a different version of AF. These are my versions:

 

  • AF Server: 2.5.2.5396
  • PI OleDb: 1.3.1.5

As a final test, I have also tried to run a default query from PI SQL Commander, but I am getting the same error:

Restarting the PI OleDb Enterprise does not seem to help.

Is it a known issue? How can it be solved?

Outcomes