AnsweredAssumed Answered

UFL: files(.csv or .txt) needs to be dump by 2x

Question asked by RoyRobinJr on Sep 14, 2017
Latest reply on Sep 14, 2017 by dbenco

Hi sirs and maam

 

     need help for ufl configuration. i have my configuration set up and it works but it needs to be dump the file 2x to be able to get all the tags. sample ive got 20 values for 1 Pi Tag. first dump attempt then when going to Pi archive it only shows that i got 3-5 values for that 1 specific Pi tag. then when second dump attempt already shown all the 20 values on that 1 tag. can you help me what did i go wrong in my configuration? 

 

Example of a simple .csv file

  

Date&TimeH2SREMARKS
4/1/2017 0:000.005
4/1/2017 0:300.005
4/1/2017 1:000.005
4/1/2017 1:300.005
4/1/2017 2:000.005
4/1/2017 2:300.006
4/1/2017 3:000.007
4/1/2017 3:300.006
4/1/2017 4:000.007
4/1/2017 4:300.006
4/1/2017 5:000.005
4/1/2017 5:300.005
4/1/2017 6:000.005
4/1/2017 6:300.005
4/1/2017 7:000.005
4/1/2017 7:300.006
4/1/2017 8:000.007
4/1/2017 8:300.005
4/1/2017 9:000.005

 

 

 

 

 

 

 

 

 

 

 

Maybe ill paste my ini.configuration if it helps.

[INTERFACE]

PLUG-IN=AsciiFiles.dll

 

[PLUG-IN]

IFM=C:\Users\Administrator\Desktop\EDC Demo\New file For ufl\*.csv

IFS=N

REN=_OK

ERR=BAD

PURGETIME=1d

PFN=False

NEWLINE=13,10

 

[SETTING]

DEB=0

MAXLOG=10

MAXLOGSIZE=20

MSGINERROR=C:\Program Files (x86)\PIPC\Interfaces\PI_UFL\Logs\err.log

OUTPUT=C:\Program Files (x86)\PIPC\Interfaces\PI_UFL\Logs\out.log

LOCALE=en-us

 

[FIELD]

FIELD(1).NAME="Timestamp"

FIELD(1).TYPE="DateTime"

FIELD(1).FORMAT="M/d/yyyy h:mm"

FIELD(2).NAME="Value"

FIELD(2).TYPE="Number"

 

[MSG]

MSG(1).NAME="MSG_1"

 

[MSG_1]

MSG_1.FILTER=C1=="*"

Timestamp=["(*),*,*"]

Value=["*,(*),*"]

StoreInPI("H2SSS", ,Timestamp,Value, , )

 

 

 

 

Thanks!

Outcomes