AnsweredAssumed Answered

Resizing datalink formula gives data item missing error

Question asked by genericuser4 on Sep 15, 2017
Latest reply on Sep 18, 2017 by genericuser4

I am inputting formulas into an excel spreadsheet using VBA, and I run into an issue.

 

The formula I type in (with actual values substituted for ease of reading and not releasing details)

=PISampDat("\\server\data item","date1","date2","2 minutes",0,"")

It will show "resize to show all values"... if I right click and select recalculate, it will tell me the data item is missing.

 

I tried going in manually, through the pi datalink tab and manually inputting the values in the right toolbar that comes up

Data item radio button is selected

data item put in

start time put in

end time put in

time interval = 2 minutes

output cell put in

 

if I hit OK, it will put in all the values, but if I then right click again and select "recalculate", it will tell me the data item is missing.

 

Essentially, the only way I can get values to show up (and only for certain data items) is to use the actual sampled data window, and then it cannot be recalculated.

Outcomes