AnsweredAssumed Answered

UFL: ERROR MESSAGE "SET PI TIME, ARGUMENT OUT OF RANGE"

Question asked by RoyRobinJr on Sep 24, 2017
Latest reply on Oct 17, 2017 by rkoonce

HI SIRS AND MAM.

 

     Can anybody help me with this configuration. dont know what is the correct format for the date and time it always keep saying that SET PI TIME, ARGUMENT OUT OF RANGE or INVALID FORMAT DATE AND TIME. Im just a newbie here in UFL so can i request for some help.

 

Heres my example.

 

My csv file or in text file

                                                                                                                                                                                                                                                      

Ambient Temperature 20Ambient Temperature 10Relative HumidityBarometric Pressure
1/1/2017 0:0021.820.799.6808.4
1/1/2017 1:0021.720.399.6800.7
1/1/2017 2:0021.820.399.6779.5
1/1/2017 3:0021.820.499.6658.1
1/1/2017 4:0021.820.799.6746.8
1/1/2017 5:0021.820.499.6747
1/1/2017 6:0021.820.199.6820.5
1/1/2017 7:0021.820.299.6750.3
1/1/2017 8:0021.820.499.6708.3
1/1/2017 9:0021.820.799.6712.4
1/1/2017 10:0021.82199.6733.9
1/1/2017 11:0021.821.299.6772.2
1/1/2017 12:0021.82199.6781
1/1/2017 13:0021.82199.6759.9
1/1/2017 14:0021.820.899.6774.1
1/1/2017 15:0021.820.799.6783.8
1/1/2017 16:0021.820.999.6785.1
1/1/2017 17:0021.820.899.6768.3
1/1/2017 18:0021.820.899.6775.3
1/1/2017 19:0021.820.799.6780.7
1/1/2017 20:0021.820.799.6782.6
1/1/2017 21:0021.820.899.6761.7
1/1/2017 22:0021.820.999.6735.8
1/1/2017 23:0021.821.299.6722.5

 

Then my configuration in UFL is

[INTERFACE]

PLUG-IN=AsciiFiles.dll

 

[PLUG-IN]

IFM=C:\Users\Administrator\Desktop\EDC Demo\9-22-17 EDC Additional UFL\Dump folder\*.txt

IFS=N

REN=_OK

ERR=BAD

PURGETIME=1d

PFN=False

NEWLINE=13,10

 

[SETTING]

DEB=0

MAXLOG=10

MAXLOGSIZE=20

MSGINERROR=C:\Program Files (x86)\PIPC\Interfaces\PI_UFL\Logs\err.log

OUTPUT=C:\Program Files (x86)\PIPC\Interfaces\PI_UFL\Logs\out.log

LOCALE=en-us

 

[FIELD]

FIELD(1).NAME="TIMESTAMP"

FIELD(1).TYPE="DateTime"

FIELD(1).FORMAT="mm/dd/yy hh:mm"

FIELD(2).NAME="AmbientTemperature20_Value"

FIELD(2).TYPE="Number"

FIELD(3).NAME="AmbientTemperature10_Value"

FIELD(3).TYPE="Number"

FIELD(4).NAME="RelativeHumidity_Value"

FIELD(4).TYPE="Number"

FIELD(5).NAME="BarometricPressure_Value"

FIELD(5).TYPE="Number"

 

[MSG]

MSG(1).NAME="MSG_1"

 

[MSG_1]

MSG_1.FILTER=C1=="*"

TIMESTAMP=["(*) * * * *"]

AmbientTemperature20_Value=["* (*) * * *"]

AmbientTemperature10_Value=["* * (*) * *"]

RelativeHumidity_Value=["* * * (*) *"]

BarometricPressure_Value=["* * * * (*)"]

StoreInPI("AmbientTemperature20", ,TIMESTAMP,AmbientTemperature20_Value, , )

StoreInPI("AmbientTemperature10", ,TIMESTAMP,AmbientTemperature10_Value, , )

StoreInPI("RelativeHumidity", ,TIMESTAMP,RelativeHumidity_Value, , )

StoreInPI("BarometricPressure", ,TIMESTAMP,BarometricPressure_Value, , )

 

 

 

Then always keep popping up

NOTE:

I already tried this format for date and time:

mm/dd/yy h:mm -  invalid time format

m/d/yyyy h:mm - error argument out range

mm/dd/yy hh:mm - invalid time format

mm/dd/yyyy h:mm - invalid time format

mm/dd/yyyy hh:mm - invalid time format

 

Hoping for help sir and mam.

 

Thank you!

Outcomes