AnsweredAssumed Answered

Third Party Software Unable to Establish a Connection With FTHistorian Through PIOLEDB

Question asked by UsmanAmjad on Oct 5, 2017

Hi,

I am working on a project in which we are using PI System Management Tools (Historian). The scope includes receiving live data from the field into historian and from there another software will read this data to perform certain performance calculations which will be returned back to the Historian. Now this software is supposed to connect to historian via PIOLEDB connector which is currently not establishing connection between Historian and that software using the following string for explicit login:

 

Provider=PIOLEDB.1;User ID=piadmin;Data Source=WINSRVR2012R2;Extended Properties="";Integrated Security=SSPI;Persist Security Info=False

 

Then I have tried running the PIOLEDB tester in this context but it shows error -10722 (PINET: Timeout on PI RPC or System call) before opening. The screenshot of the error message is attached below.

 

Untitled.png

 

I have tried the following solutions:

1. Increased Data Access connection timeout to 120 seconds.

2. Made sure all subsystems are running on PI Server ,except for shutdown subsystem (verified from services.msc and Operation > PI Services).

3. Could not check snapshot and archive statistics because piartool cmd window pops up and closes by itself when I click to open it.

 

Apart from this, I have also made the following findings:

1. In PI SMT Operations > Licencing > Programs 'PI-OLEDB.Default: Undefined' is marked with a small red cross on its icon.

2. In PI SMT Security > Security Settings I have already disabled all the securities (slider moved to the bottom) so, I suppose the above string must work on our Third Party software to explicitly connect via PIOLEDB.

3. I read in an article on this website that trusts must be added for PIOLEDB and any other software that is trying to connect to PI SMT so I have added for both PIOLEDB and our Third Party software, I was not sure about the IP Addresses so, I used the IP Address of !Proxy_127! which was added to it by default.

 

111.png

 

I am rookie to using FTHistorian so, potential solutions in easy to understand language shall be highly appreciated.

 

Thanks

Usman

Outcomes