AnsweredAssumed Answered

PI JDBC 2016 - Native Library Version is wrong

Question asked by joe.ruth on Nov 17, 2017
Latest reply on Nov 17, 2017 by vkaufmann

I am getting the following java stack trace when attempting to access PI AF via the JDBC driver:

 

ERROR 2017-11-17 07:12:51,989 SYSTEM stack-trace Native Library Version (unknown) is wrong. Required : 241

ERROR 2017-11-17 07:12:51,989 SYSTEM stack-trace com.osisoft.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:81)

ERROR 2017-11-17 07:12:51,989 SYSTEM stack-trace com.osisoft.jdbc.DriverExtension.connect(DriverExtension.java:121)

ERROR 2017-11-17 07:12:51,989 SYSTEM stack-trace com.osisoft.jdbc.Driver.connect(Driver.java:261)

ERROR 2017-11-17 07:12:51,989 SYSTEM stack-trace java.sql.DriverManager.getConnection(DriverManager.java:664)

ERROR 2017-11-17 07:12:51,989 SYSTEM stack-trace java.sql.DriverManager.getConnection(DriverManager.java:247)

 

Any ideas?  Versions installed are PI JDBC 2016, PI SQL DAS 2016 R2, and PI OLEDB Ent 2016 R2 (just grabbed the latest from the download area).

The only other thread I saw on this topic said something about JRE not installed, but I do have that...1.8.0 update 131.

Maybe some sort of configuration setting I have wrong?

Outcomes