3 Replies Latest reply on Nov 27, 2017 3:01 PM by gmichaud-verreault

    pi base susbsystem crashing

    sytahmed123

      Hi,

      I have a issue with a customer Historian Server.

      PI Base Subsystem crashing quite randomly. I mostly happens when:

      1) I open the PI-SMT as an Admin.

      2) when i click on PI-SDK > connection and on server

      3) try to open the Trend on vantagepoint Trend

      4) when i try to check the Mapping setting on PI-SMT

       

      It used to work without problem but i dont know but IT has been changed smth on my user account.

       

      Any help will be highly recommended

        • Re: pi base susbsystem crashing
          gmichaud-verreault

          The PI Base Subsystem on the PI Data Archive server is crashing when your perform those steps!? Does it start back up successfully whenever your restart it?

           

          I would first start off by taking a look at the PI Message logs and the Windows Event Viewer (app/system) to see if you can see what error caused the crash. Also, what version of the PI Data Archive and the SDK are you using?

           

          Gabriel

            • Re: pi base susbsystem crashing
              sytahmed123

              Hi Gabriel,

              Thanks for the reply.

              Not all the time Service restarts successfully.

               

              In the message Log, the exact time when the PI Base Subsystem Service crashed the error was "Error Storing Usage Data-[-10733] PINE:RPC Resolver is Off-Line"

               

              Also, I can see a lot of Errors "PIarcmgr:addevent failed mode: 1 ptid: 147recid: 14624542 status:[-11002] Record Header Data Mismatch event time".

              1)

              Faulting application name: pibasess.exe, version: 3.4.390.18, time stamp: 0x50ce7eb3

              Faulting module name: ntdll.dll, version: 6.3.9600.18790, time stamp: 0x598d24e0

              Exception code: 0xc0000374

              Fault offset: 0x00000000000f1c00

              Faulting process id: 0x21e4

              Faulting application start time: 0x01d35d2558b67aaf

              Faulting application path: C:\Program Files\Rockwell Software\FactoryTalk Historian\Server\bin\pibasess.exe

               

               

              2) In the Application Logs below are the errors I can see:

              Fault bucket , type 0

              Event Name: APPCRASH

              Response: Not available

              Cab Id: 0

               

               

              Problem signature:

              P1: wmiprvse.exe

              P2: 6.3.9600.18264

              P3: 56e1bc63

              P4: StackHash_5cb6

              P5: 6.3.9600.18790

              P6: 598d24e0

              P7: c0000374

              P8: PCH_56_FROM_ntdll+0x0000000000090C7A

              P9:

              P10:

              These files may be available here:

              C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_wmiprvse.exe_e717923b6092cb1dcff6565b51ecfa40111c1498_bb013a4e_3375fff5

              Also,

              Faulting application name: wmiprvse.exe, version: 6.3.9600.18264, time stamp: 0x56e1bc63

               

              in the System Log, the error I am getting are:

              1) The PI Base Subsystem service terminated unexpectedly.  It has done this 18 time(s).

              2)

              The system failed to register host (A or AAAA) resource records (RRs) for network adapter

              with settings:

                         Adapter Name : {91DA2A4C-9C50-4E0D-8A4E-6B5AA29F0F64}

                         Host Name : UKLOUR63

                         Primary Domain Suffix : euro.mmm.com

                         DNS server list :

                            169.4.68.68, 169.4.68.58

                         Sent update to server : <?>

                         IP Address(es) :

                           169.5.122.196

               

              OISsoft.PISDK File Version is: 1.4.0 and Assembly Version: 1.4.2.445