AnsweredAssumed Answered

PI OLEDB Enterprise Error on Large Query

Question asked by DanielFynes on Dec 1, 2017
Latest reply on Jan 9, 2018 by DanielFynes

Hi Guys,

 

I'm doing a Dynamic Transpose archive query that should return about ~50 000 rows (largely PI Data) and ~30 columns and it is failing with both PI SQL Commander and with another Data Warehousing application with the error "Arguments are invalid". I have the OPTION (IGNORE ERRORS, EMBED ERRORS) at the end of my query but this does not seem to be a typical PI/AF SDK error. Furthermore, if I run the query with a time period 2017-01-01 to 2017-07-01 it returns ~36000 rows and if I run the query from 2017-07-01 to 2017-08-30 it returns ~12000 rows. However, if I run the query from 2017-01-01 to 2017-08-30, it gives the error "Arguments are invalid". Therefore, because I can query the data for the time period in two queries, I don't think it is an error with the data but rather a memory/settings timeout. I do have my query timeout set at 300 secs, while the query will typically throw the error after ~2 mins. I have tried doubling the ArcMaxCollect setting of the PI server but this did not seem to help. I can't seem to find the log files for OLEDB enterprise and nothing in the event logs of either the client or server. Any help or ideas would be much appreciated! 

Outcomes