AnsweredAssumed Answered

Rt Reports "Maximum request length exceeded"

Question asked by Patricia_Altran on Jan 15, 2018
Latest reply on Jan 15, 2018 by gregor

Hi all!

 

I'm trying to import a template in a Rt Reports editor. I have the data template and the format template.

 

When I try to save the import I get the following error:

 

 

Searching in the Rt Reports Administrator Guide I found that:

"When running the editor, the following error may occur: "There was an exception running the extensions specified in the config file. - > Maximum request length exceeded." This is because the size of the report template exceeded 2048 Kbytes. To fix this change httpRuntime.maxRequestLength in machine.config to 4096."

 

In my server that value is 8192 and I changed it to 16384, 32768, 65536, 131072 with the same result.

 

I have tried to import both templates separately and the error doesn't appears if I import only the data template and neither if I try to import only the format template. The problem is when I try to save the import of both templates.

 

Anyone knows how to fix that?

 

More information:

RtReports editor version: 3.3.0

RtReports server version: 3.3.0

RtReports editor version (where templates are created): 4.0.0

 

(I have been able to import other templates from the same RtReports editor)

 

Thanks!!

Patricia.

Outcomes