6 Replies Latest reply on Mar 7, 2018 2:50 PM by Tomas Stark

    Auto-backfilling interval limit (72 hours)

    Tomas Stark

      Hi,

       

      after the upgrade to PI AF 2017 R2A this message shows up for all analyses where we have performed a backfill previously.

       

      What is this 72 hour limit? When I made a new backfill a couple of weeks back in time, the indicator turned green and everything seems to work as previously.

       

      180214 Skärmklipp Backfill.jpg

       

      Regards,

      Tomas

        • Re: Auto-backfilling interval limit (72 hours)
          Dan Fishman

          That has to do with automatic backfilling when PI Analysis Service is down.  PI Analysis will automatically backfill data if it is shutdown for less than 72 hours.  Upon startup, this allows you to automatically recover gaps on a shutdown and have the analysis service immediately start processing real-time data. I see in your case, the 72 hour automatic backfill limit was exceeded.  You can perform a manual backfill to fill the gap. 

           

          Per Live Library:

          MaximumAllowedAutoBackfillingSpanInHours

           

          Specify the maximum downtime (in hours) for the PI Analysis Service to initiate automatic backfilling. Setting the parameter to "0" or a negative number will restore the previously recorded setting for this option. If you update this setting, you must restart PI Analysis Service.

           

           

          4 of 4 people found this helpful
          • Re: Auto-backfilling interval limit (72 hours)
            sraposo

            Hi Tomas,

             

            Did Dan Fishman's solution resolve your issue?

             

            It's the correct solution. Was your analysis server or AF Server down from the 8th of Jan to the 2nd of Feb ?

             

            Thanks,

            Seb

              • Re: Auto-backfilling interval limit (72 hours)
                Tomas Stark

                Hi Sebastien,

                 

                no, our AF Server was not down during that time. Only a short restart for 30 minutes or so.

                 

                I did another check on this. We have data that is manually entered approximately every two weeks in another system. We do an event-triggered table lookup to fetch data from that system and store the data in PI tags.

                 

                We did backfilling the first time we set this up, but since there is no way to disable backfilling (or is there?) we will still have the green symbol or the red exclamation mark in the backfilling column.

                 

                Fetching new data and storing it in the PI tag works well, but we get the 72 hour limit error message when PI tries to backfill the data and the 72 hour time period has passed from the previous timestamp of the PI tag (2018-02-19 15:01:10). When I do a manual backfill (in this case 30 days), it will change to the green symbol.

                 

                So it seems in this case the 72 hour limit has nothing to do with the AF Server being down for that time period (which it hasn't been), but rather that the backfilling is always on and it has passed more than 72 hours since the timestamp of the last data.

                 

                180307 Skärmklipp Back-fill 1.JPG

                 

                180307 Skärmklipp Back-fill 3.jpg

                 

                Regards,

                Tomas

                  • Re: Auto-backfilling interval limit (72 hours)
                    Tomas Stark

                    Hi again,

                     

                    I checked up the date and time 2018-03-02 17:13:34 in the image above, and that was the time the PI Analysis Service was up again after a short restart of the PI AF Server. So it seems this 72 hour limit is checked by the PI Analysis Service (or rather PIRecalculationProcessor?) and if there has not been any data stored with a time stamp within this 72 hour period, it will set the red exclamation mark with the error message.

                     

                    So, how do we turn off backfilling for these analyses? They only slow down the system and was only needed at setup time.

                     

                    Tomas