2 Replies Latest reply on Feb 16, 2018 9:43 AM by Tomas Stark

    PI Analysis auto-backfill on startup

    acote

      Hello PI Square geeks,

       

      I have PI Analysis Service mounted on a Windows failover cluster and supporting > 2000 analysis...

       

      When a failover occur or at service startup, ALL analysis configured for backfilling executes based on the last configured backfill/recalculate timerange.

       

      That is definitly scary!!! with dozen of formerly trained power-users (myself included) allowed access to our AF System, I frequently find:

            - last backfill to be at a specific date (ex: 2016/01/01 which was executed on 2016/01/02 with the range "2016/01/01 to *"),

            - backfill that are configured for analysis with no output to PI Points, 

            - Analysis that take advantages of the PI Server Snapshot & Compression to generate data that would not be identical on recalculation, but with manual backfill useful in certain scenario and damaging in others.

       

      3 questions:

      - How do I remove backfilling from a specific analysis?

      Option to remove Backfill on a specific analysis PI Server: Hot (496 ideas) – Customer Feedback for OSIsoft & the PI System

      - How do I completely remove the auto-recalc au service start-up?

      - Does anyone know the plan toward which OSIsoft is going to make this system more "manageable"?

       

      Default Backfill configuration for service startup PI Server: Hot (497 ideas) – Customer Feedback for OSIsoft & the PI System

       

      thanks for your help...

       

      Alex

        • Re: PI Analysis auto-backfill on startup
          rschmitz

          Hi Alexandre,

           

          Starting in PI AF 2017 R2 you can enable of disable automatic recalculation on analyses in the management tab of PI System Explorer. Please see our User guide for more information on this topic.

           

          To disable backfilling on startup of the analysis service altogether, you would need to edit the Service Configuration for the Analysis Service in the config database in PI AF. That being said, it sounds like the above solution is what you really want.

           

          Cheers,

          Rob

            • Re: PI Analysis auto-backfill on startup
              Tomas Stark

              Hi Robert,

               

              I tried to disable automatic recalculation for a specific analysis, and after acknowledging that it would affect all analyses made with the same template, I got this message under "Pending Operations".

              180216 Skärmklipp Backfill.JPG

              I guess the Complete flag means it has now been processed, but still half an hour later (and after a Refresh) I will see the backfilling flags in the Analyses tab of the analysis.

              180216 Skärmklipp Backfill 2.JPG

              Shouldn't these have been removed by now?

               

              Best regards,

              Tomas