7 Replies Latest reply on Feb 27, 2018 8:04 AM by Malleswararao Giduthuri

    issue on Peformance equation

    Malleswararao Giduthuri

      Hi,

       

      We have two production servers, each running on independent PI PE schedulers. We have an issue where two PE tags are not updating on secondary PI server but updating fine on primary PI server. I have created a test tag with same configuration but didn't get success. No success even after refreshed (scan off & scan on) the PI tag.

       

      Note: Source tags are updating fine on both the PI servers.

       

       

      Thanks,

      Mallesh.

        • Re: issue on Peformance equation
          KenjiHashimoto

          I believe you are using PI Collective (PI HA) configuration. In that case, secondary PI Data Archive pe tags are updated by PE scheduler on secondary PI Data Archive machine.

          Is your pe schoeduler service on secondary node running?

          Check PI Message logs, PIPC logs on secondary PI Data Archive machine.

            • Re: issue on Peformance equation
              Malleswararao Giduthuri

              Hi Kenji,

               

              Thanks for your email. We are using collective members but PE schedulers are running independently.

               

              PE scheduler is running fine on secondary PI server, we have 10000+ tags (approximately) in secondary PI server which are running fine. We have an issue with only two tags. I have tried to update the scan frequency but there is no success.

               

               

              Thanks,

              Mallesh

                • Re: issue on Peformance equation
                  KenjiHashimoto

                  Good. Only 2 tags have problem.

                  I believe your screen shot comes from PI ICU. So scan class is 13, right?

                  Does it come from secondary PI data archive machine's ICU?

                  There are possibilities that users set only new scan class for primary machine and forget to add it to the secondary machine.

                  Since PE scheduler on primary and seconday PI Data Archive run independently, we need to take care of it.

                  (Also forget to restart the service too)

                  It is good to check logs on Secondary PI data Archive too.

              • Re: issue on Peformance equation
                sraposo

                Hello,

                 

                Have you confirmed that the inputs to your PE equations have data on your secondary PI Data Archive? Anything useful in the SDK logs?

                 

                Thanks,

                Seb

                1 of 1 people found this helpful
                  • Re: issue on Peformance equation
                    Malleswararao Giduthuri

                    Hi Kenji,

                     

                    Yes, scan class is 13. There are 1000+ PE tags are running on this particular scan class and updating fine on both the PI servers except two tags. These tags have data on secondary server until 13th Feb. There was no change happened. I have debugged the tag and tried to refresh (scan off & scan on) the tag but seems to be no success. I have tried to give new set of scan class but no success. There was no logs which are useful for this issue.

                     

                    Hi Raposo,

                     

                    I can confirm source tags have data on secondary server.

                     

                    Thanks,

                    Mallesh