2 Replies Latest reply on Mar 7, 2018 12:44 AM by Shanshan

    PI Vision installation issue

    Shanshan

      Hi everyone,

       

      I have recently subscribed to PI Developers Club and successfully installed PI  Data Archive, PI AF, PIDatalink. But the installation of PI Vision was not successful. 'Installation Error' popped up at the end of the installation, saying the followings are not installed.

      - IIS URL Rewrite Module 2,

      - PI Vision 2017 R2, Microsoft System CLR types for SQL Server 2014,

      - Microsoft SQL Server 2014 Management Objects,

      - PI Vision 2017 R2 Display Utility 

       

      What could be the issue here? Does PI Developer License have access to PI Vision? Or was there any prerequisite software that needs to be installed first?

       

      thank you!

        • Re: PI Vision installation issue
          Lal_Babu_Shaik

          Hi Shanshan

           

          Specific to error reported :

           

           

           

           

          Web Server Role (IIS) should have following permissions

           

          Management Tools :

           

          • IIS Management Console (Not
            applicable for the Server Core
            minimal installation option in
            Windows Server 2012 and later)
          • IIS Management Scripts and Tools
          • Management Service

           

          Role services :

          • HTTP Errors
            HTTP Redirection

          Please refer PI vision Installation and Administration user guide for additional information. 

           

          Please find the pre-requisite software required.

          Operating Systems

          Microsoft Windows Server 2008 R2 SP1 64-bit, or later

          Software Requirements

          • Microsoft SQL Server 2008 R2 and later
            • Standard, Enterprise, or Express
            • Note: If not on the application server itself, it
              is strongly recommended that the database be in the same domain as the
              PI Vision application server and PI System
          • Microsoft .NET Framework 4.6 (included in install kit)
          • Microsoft Internet Information Services (IIS) 7.5 and above

           

           

           

          4 of 4 people found this helpful