4 Replies Latest reply on Mar 23, 2018 1:17 PM by JIrnsinger

    trigger analysis on late arriving data sometimes does not work

    JIrnsinger

      Hello everybody,

       

      i have the following problem (AF server version 2.9.5.8368):

       

      For a lot of TAGs we have late arriving data (+ 50 days). So for example the values are available on the 20th of march and are written on a timestamp at the beginning of the previous month (1st of February). Theses values are the inputs for some analysis and the output is written on TAGs (timestamp 1st of Feb). In some cases this works very fine in some cases the analysis is not triggered although everything in configured the same.

       

      So I made some tests with one of the input-TAGs for wich the triggering of the analysis did not work:

      1. At first I deleted the values on 1st on Feb and 1st of Jan and then wrote the original value again on the same timestamps. The analysis still was not triggered.
      2. Then I wrote a value on a timestamp close to "now" (Beginning of the day). This did trigger the analysis and the output was written. After that I deleted the values from this test (timestamp: Beginning of the day) on the input and the output TAGs.
      3. Then I tried again the first step (rewriting the values on 1st of Feb and 1st of Jan) with the result that now the analysis was triggerd and the output was written.
      4. I could reproduce this behaviour with the other TAGs for wich the triggering did not work.

       

      Can someone explain this behaviour? How can I make sure that the analysis for the late arriving data is triggered? In all cases Auto-Reclac was activated.

        • Re: trigger analysis on late arriving data sometimes does not work
          Gerhard Polenz

          I cannot explain the observed behavior, but want to mention some things that may have an influence on your test:
          1. for the tag that receives the output: what are the settings for exception and compression? To avoid you miss any values, set ExcDev and ExcMax to 0 to disable exception and set Compressing to 0 to disable compression

          2. except for out-of-order events: what did you do to delete the values? Remove them from the archive? Consider that a value may still be in the snapshot table!

           

          Finally a very basic comment: what is your setting for MaxAllowedAutoRecalculationSpanInDays? Is that great enough to cover the period of time for which you re-wrote a value? Default of that value is 180 days so unless you changed that it is very likely it covers the time back until begin of the year.