8 Replies Latest reply on May 23, 2018 1:50 PM by rschmitz

    error in log System managment tool

    rodrigocapurro

      HI, system managment tool throw the following error: [Server] AREPBUE-APPI01 [ID] 4 [Time] 4/19/2018 8:04:00 AM [Program] SRyTD_EnapSvc [Priority] 10 [ProcessOSUser] main.glb.corp.local\AREPBUE-APPI01$ [ProcessID] 3356 [Severity] Information [Source1] PISDK  Unable to obtain the impersonation request token from the server. Continuing with buffer registration  This server version doesn't support impersonation requests. : 0x800404e1, can you help me?

        • Re: error in log System managment tool
          rschmitz

          Hi Rodrigo,

           

          It looks like you may be running into this known issue which has not been resolved yet. This message only occurs when using PI SDK buffering of data to the Data Archive. The Buffer is unable to impersonate the end user running the application trying to write the data, so it uses it's own PI Identity for authentication (which may or may not have higher priv's than the end user running the application). You can read more about this in KB00572.

           

          Cheers,

          Rob

          3 of 4 people found this helpful
            • Re: error in log System managment tool
              rodrigocapurro

              HI,

               

              check the documentation they told me, but how do I stop this error from happening?

               

              The SMT throw error:

              [Server] AREPBUE-APPI01 [ID] 4 [Time] 4/20/2018 1:23:00 PM [Program] SRyTD_EnapSvc [Priority] 10 [ProcessOSUser] main.glb.corp.local\AREPBUE-APPI01$ [ProcessID] 6524 [Severity] Information [Source1] PISDK

              Unable to obtain the impersonation request token from the server. Continuing with buffer registration  This server version doesn't support impersonation requests. : 0x800404e1.

               

              this is a service that uses quartz to query data in PI and create a .txt file every 1 minute

              • Re: error in log System managment tool
                rodrigocapurro

                HI Robert

                 

                I still can not solve this problem, I tell you again, I have a service that connects to PI every 1 minute to send information through a text file and this error continues to be generated:

                 

                [Server] AREPBUE-APPI01 [ID] 4 [Time] 4/25/2018 12:00:00 PM [Program] SRyTD_EnapSvc [Priority] 10 [ProcessOSUser] main.glb.corp.local\AREPBUE-APPI01$ [ProcessID] 11544 [Severity] Information [Source1] PISDK

                Unable to obtain the impersonation request token from the server. Continuing with buffer registration  This server version doesn't support impersonation requests. : 0x800404e1

                 

                How can I stop this error from occurring?

                 

                best regards

                  • Re: error in log System managment tool
                    ckirkland

                    Hi Rodrigo,

                     

                    As Rob mentioned, this is currently an unresolved known issue. Thus, we cannot do anything to prevent this message at this time. However, this error only indicates that the Buffer Subsystem will be authenticating with its own credentials instead of the custom application's credentials. If the difference between the credentials of the custom application and that of the Buffer Subsystem is not causing you any problems, you are safe to ignore this message. However, we can not do anything to prevent it.

                     

                    Cody

                      • Re: error in log System managment tool
                        rodrigocapurro

                        good morning, there is another error that is giving us the SMT, below destallo the description of it

                            

                        • Failed to cancel buffer registration: [-11441] The buffering key is invalid”

                         

                         

                        How can I solve this problem?

                         

                        Best regards

                          • Re: error in log System managment tool
                            rschmitz

                            Rodrigo,

                             

                            There are a couple of known issues which can cause this error to appear:

                             

                            On PI Buffer Subsystem Versions prior to 4.3, if multiple threads in a process are buffering to the Data archive this can occur. (Link)

                            Similarly, if the buffer was not properly disconnected by the process this can occur with versions prior to 4.3 (Link)

                            As well as in certain cases with the SDK prior to 1.4.4.484 (Link)

                             

                            I would ensure that you're running on pi buffer subsystem 4.4 or newer and at least PI SDK 1.4.4.484 or newer. If both of those look in order, then it is likely worth opening up a tech support case to look into your custom application to get some more information.

                             

                            --Rob

                            1 of 1 people found this helpful
                    • Re: error in log System managment tool
                      rodrigocapurro

                      HI,

                       

                           thanks for the reply. I have other questions, I made a program that connects to PI and reads a single tag, in doing so, throws the following logs in SMT:

                         

                           1) Buffer Registration succeeded. Server: xxxxxxx-xxx source app: TestPI.exe, source app PID: 10032, domain user: NT AUTHORITY\SYSTEM, buffer mode: FanAndBuffer, buffered data type: 1

                           2) Removed buffering key. Source app: TestPI.exe, source app PID: 10032, domain user: NT AUTHORITY\SYSTEM, buffer mode: FanAndBuffer, buffered data type: 1

                           3) Cancelled buffer registration. Source app: TestPI.exe, source app PID: 10032, domain user: NT AUTHORITY\SYSTEM, buffer mode: FanAndBuffer, buffered data type: 1

                       

                         Is this related to the same thing that they answered before?

                       

                       

                        is there a way to make them disappear?

                       

                      Best Regards