AnsweredAssumed Answered

Having issues testing GetSnap/ accessing PI SDK using Java

Question asked by hiella on Aug 20, 2018
Latest reply on Aug 20, 2018 by vkaufmann

Hi,

 

I've been trying to access PI OLEDB using Java. I have the latest PI JDBC and PI DAS installed on local computer (A), and the target DB is in another computer (B) but same network. I basically copied the code from examples when installing the JDBC.

 

And I get the following error message all the time: "Connection failed. Connection reset."

 

I am not showing all the code here because I get the same error message when I test using GetSnap.

 

Do anyone have any thought on this? I have a few assumptions after I did some research:

1) The PI DAS should be installed in the computer B where the DB locates;

 

2) According to the PI JDBC Driver 2018 Administrator Guide, this is a "Missing or not suitable SSL certificate" issue (In local computer A, I tried to follow the steps on Using the Keytool to Import a Certificate in the Developing with PI Web API, but I cannot export the certificate in .cer format.) Both computer A and B do not have any internet connection--not sure if this is related.

 

3) Something wrong with my connection string. Here's my url: "jdbc:pioledb://computerB.companyname.com/Data Source=computerB.companyname.com; Integrated Security=SSPI;"

 

I am using port no. 5450 since that's the port no. used my PI SDK Utility, and the computerB.companyname.com is from there too. Here's the rest of the properties:

String enableCertificateValidation = "No";

String isTrustedConnection = "Yes";

String useDCA = "No";

String userName = "";

String password = "";

String portNumber = "5450";

String logLevel = "0";

 

Outcomes