AnsweredAssumed Answered

PI webparts - Not able to make my PI Graphic dynamic w.r.t PI treeview

Question asked by Kiran324 on Oct 29, 2018
Latest reply on Oct 31, 2018 by Roger Palmen

Hello Everyone,

 

Recently I have been facing an issue but not able to resolve it despite the concept seeming simple and giving ample time.

 

I have a ProcessBook display which have texts, some data as ERD and some as AF2 attributes.

I have saved the display in .svg format.

Now while using PI webparts, first I am uploading PI treeview webpart and I am able to successfully import my hierarchy. (Note - I have not created a parent element, but under my database I have directly created 8 elements with same templates).

My heirarchy seems like this -

server>database > 8 elements (I want to import attributes of these elements)

 

So the root node of my tree is - \\server\database

while for default selected node I have - \\server\database\element1

 

Then I have tried importing my svg file as PI Graphic webpart.

I am able to browse and see my exact display as expected.

 

Then I had set up connection among the two using -

Send client side parameter to PI Graphic - (for PI treeview)

Get client side parameter from PI Treeview - (For PI Graphic)

 

But after these steps, when I select "element2' or 3 or any other from my PI treeview, the PI graphic doesn't change the value. It is not dynamic and shows a fixed static value.

 

It will be great if someone can help me with what I am missing or where I am going wrong.

 

Thank you,

Kiran Rao

Outcomes