10 Replies Latest reply on Nov 15, 2018 3:52 PM by dpfahler

    Search Service Administration "Authorization has been denied for this request."

    dpfahler

      Dear Community,

      I am trying to add an Indexed Search Crawler to my PI WebAPI.

      When trying to set up a search:

      https://<<SERVER>>/piwebapi/search/query?q=name:*

      It returns an empty list:

      {
      "Links": {},
      "Errors": [],
      "Items": []
      }
      

      I am sure that the Indexed Search Crawler is not crawling my data, similar as in this Question:

      Authorization has been denied for this request

      I tried everything suggested by its answer but it still does not work. Then I found this Question:

      "Authorization has been denied for this request." when adding database for PI Web API

      Sadly they didn't post the answer. My search guided me to this question,

      Indexed Search Crawler Not Finding PI Points

      which has some promising answer:

      "I Web API Search Crawler does not recognize PI Data Archive/AF security mappings that are mapped to Local Windows groups. I had a catch-all mapping for the generic user to have read-only access: BUILTIN\Users. Once I added my domain account and domain group explicitly, it worked."

      I added the properties:

      but it still does not work.

      I would be very grateful for any kind of help.