2 Replies Latest reply on Jan 9, 2019 2:02 PM by Mike Horrocks

    Osisoft Datasourse configuration settings on Grafana

    banudur

      Hello,

       

      I am new on Grafana and I've tried to add Osisoft-PI as datasource on it. I setted the configuration settings by looking at the articles (It says setting proxy access setting and basic authentication) but I couldn't find how to adjust proxy settings and configure API Key (I created an API Key but I don't know where to use the key). So I've just add server acces, but it gives errors like "HTTP Error Bad Gateway" or "HTTP Error Unauthorized". Could you help me about it? Thank you in advise.

       

      Best regards!

       

      OsisoftConnectionError.PNG

        • Re: Osisoft Datasourse configuration settings on Grafana
          Lal_Babu_Shaik

          Hi Banu,

           

          Request you to check authentication in PI Web API  (Configuration).i.e. authentication set to Basic or Kerberos.

           

          Thanks,

          Lal

          • Re: Osisoft Datasourse configuration settings on Grafana
            Mike Horrocks

            Hi

             

            Are you using the cloud hosted Grafana? If so, the problem is that your PI Web API endpoint is not resolvable from the Internet. In this configuration the HTTP Access is set as "Server (Default)", which means that the Grafana cloud instance is making the calls to the PI Web API and if it cannot resolve the URL it will fail.

             

            If you're running locally, I'd check the same thing - can the host of Grafana correctly resolve the URL you have entered?

             

            I have a cloud hosted Grafana instance connecting to my PI Server using this exact same configuration but my HTTP URL is exposed to the Internet.

            1 of 1 people found this helpful