5 Replies Latest reply on Mar 12, 2019 12:52 PM by TDurand

    AF Server - TCP error 10022

    TDurand

      Hello,

       

      After installation, the AF server can’t start properly.

      In the Event Viewer, I have the following error for AF:

       

      Exception in OnStart: A TCP error (10022: An invalid argument was supplied) occurred while listening on IP Endpoint=0.0.0.0:5457.

       

      I was suspecting a problem with the permissions, but I can’t find any missing.

       

      Does anyone know about this issue?

       

      Thank you for your help.

        • Re: AF Server - TCP error 10022
          sraposo

          Hi Thierry,

           

          The error suggests that there is an issue with the AFService.exe.config file. Notice that there is no IP address specified for the AF Server ( while listening on IP Endpoint=0.0.0.0:5457).

           

          If it's possible I'd try uninstalling and reinstalling the PI AF Application Service.

           

          Which version of PI AF are you installing?

           

          Thanks,

          Seb

            • Re: AF Server - TCP error 10022
              TDurand

              I uninstalled and reinstalled the PI AF Application Service, but it didn’t make a change.

              I am using PI AF Services 2016 R2 on Windows server 2016.

               

              I didn’t do any manual edit to that configuration file. Where should I check in this file?

              I found reference to endpoint net.tcp://localhost:5457/AFServer/service

               

              Thank you for your help.

            • Re: AF Server - TCP error 10022
              TDurand

              Sorry for the late reply,

               

              I did check the Administrative access, restart the machine, and confirmed the server didin't start with telnet and netstat.

              I thought this IP address should not be a problem in the context of a server, where it points to all IPv4 addresses on the local machine.