AnsweredAssumed Answered

AFSDK .NET version support

Question asked by Noga on Mar 6, 2019
Latest reply on Mar 8, 2019 by rdavin

Is it possible to use the Microsoft .NET v4.5 framework for the latest AF SDK v.2.10.1 (from 2018)?

Or must I upgrade the .Net version to v.4.2.6?

 

From the OsiSoft overiew link: Overview

"The AF SDK is designed for easy access from Microsoft .NET languages like Visual Basic .NET (VB.NET), C#, and Managed C++. The AF SDK is available for .NET 3.5 and .NET 4.6.2 Frameworks and targets Any CPU so that it is available for both 32-bit and 64-bit Windows operating systems."

 

 

I do not want to use the .NET v3.5 AFSDK version because I want to use the enhanced data.

Outcomes