AnsweredAssumed Answered

PIExportMode.Flat does not flatten the xml file

Question asked by Noga on Mar 13, 2019
Latest reply on Mar 18, 2019 by jshaver

I installed PI AF server PI-AF-Services_2017-R2-update-1, and I use the latest AF SDK v.2.10.1 (2018).

Using the PI System Explorer, I am trying to export Elements from the server after checking the "Flat" box option. But the xml file of all objects exported are not flat.

Also, when I use the PISystem.ExportXml method with the PIExportMode.Flat option, the files exported are still not flatten.

This oppose a problem to me when trying to import these xml files to another PI-AF server without using the PIImportMode.PreserveUniqueIDs flag, since the import updates and adds Elements to the wrong location on the PI-AF server.

 

By saying that the xml is not flat, I mean that on the <Name> element of the <AFElement> in the xml file, the name of the Element is not the full path to the Element, but only the Element end-point name.

 

Only when exporting the full Database, the flat mode applies.

 

Is this a known issue? or maybe I am missing something?

 

How can I import xml of Element to a PI-AF server without using the PIImportMode.PreserveUniqueIDs and without using the PIImportMode.AutoCheckIn flags?

Outcomes