AnsweredAssumed Answered

Coresight not loading Processbook when it contains an image

Question asked by viul on Jul 8, 2019
Latest reply on Jul 9, 2019 by jru

Hi,

 

Our Coresight does not load some Processbook files. I stripped one of the file piece by piece and discovered that it would not load with embedded images present. Furthermore, in Event Viewer we get errors in OSIsoft-PISymbols like this:

 

Error importing display XX\YYY\Display3, An error occurred while updating the entries. See the inner exception for details.

 

This only happens for processbook files for a single production machine. These are the only images created by one company (starts with "SIE"), all other images were created by ourselves or other vendors.

 

When i remove the two images present in processbook, the file loads. I tried repainting and saving the smaller of the two graphics, I tried different formats (bmp, png, jpg). The graphics are smaller than 1000*1000 px. With graphics present, the file does not load. (I tried embedding a paint object but this obviously does not work for Coresight because of OLE foo)

 

I restarted the machine this morning, did not help.

 

We moved the database last month from C: to D: drive, I don't know if this caused the problem because the error log does not go back this long, but all other existing pdi are working and new pdi without embedded images also get imported, so i doubt it.

 

And last, our configuration displays an X next to the database (see image). I'm not sure what this means, as the rest of our Coresight is working. Also Display Management and User Settings show An error occurred while processing your request, but I think that's a permission problem.

Do you have any pointers, ideas or even a solution for this?

 

Best Regards,

Viktor

Outcomes